Lightroom 41: xmp metadata sync between Mac and PC - fail!

  • 1
  • Problem
  • Updated 6 years ago
  • (Edited)
Lightroom 4.1 RC - I am trying to sync keywords between Mac and PC versions of Lightroom. So I make sure I write metadata to files on my Mac, and I verify that the keywords are in the xmp sidecar (the case with .nef raw files) - then, I copy xmp to my PC computer, and tell LR there to read metadata from files. When it is done, none of the keywords from Mac are imported. I investigated a little and the issue seems to be with the xmp file format - as it is copied from Mac computer, something gets screwed up with txt format inside xmp file - I see all the lines of text jumbled together, like CR symbols are missing or something like that. Anyway the result is that every time LR on PC reads from xmp file copied from MAc, it just overwrites it with its own version, NOT READING ANYTHING. And it does that silently, without informing the user that there was a problem reading metadata.
This is a bug, so it seems.
Can anyone verify?
Photo of shura.shum

shura.shum

  • 12 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 1
Photo of shura.shum

shura.shum

  • 12 Posts
  • 0 Reply Likes
I am not sure this happens 100% of time with all xmp files: I have a catalog of over 50000 images, and some keywords did get synced. However, some did not. I can attach the sample xmp file from my Mac that definitely has the problem being read properly on PC, if somebody tells me how to attach file to message here.