Lightroom: Wrong naming convention when exporting images with "publish services"

  • 1
  • Problem
  • Updated 6 years ago
  • (Edited)
I'm making a "Publish service" that is going to export images to a specific folder on my hard drive, but I can't get the service to name the files correctly. I have created "smart folders" that gather the images based on rating and year and the images end up in the right folder. But since the folders are going to contain hundreds of images I want them to be named after the folders they are stored in on my harddrive (and filename), for example: "2007-01-05_dinner-with-Paul_DSC0347.jpg". In the settings I am able to choose this option, but then, after I have agreed to republish all my images again, the files only gets named with their original filename, not the folder name. Hence: impossible to sort. What to do?
Photo of Johan W

Johan W

  • 1 Post
  • 0 Reply Likes

Posted 7 years ago

  • 1
Photo of Beat Gossweiler

Beat Gossweiler

  • 238 Posts
  • 36 Reply Likes
Is this a new published folder, or have you changed the naming conventions after you had already published some images?

I recently noticed that renaming is not what you specify if you change the naming scheme after already having published some images.

Workaround is to create a new published folder(-set) and setup the smart folder(s) again (possibly by exporting/importing them).

Photo of Foto VI

Foto VI

  • 77 Posts
  • 6 Reply Likes
Do you still have this problem?
I experience something very similar: