Photoshop: Wrong default input language

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)
Hello!

I have two input languages/keyboard layouts active in my Windows 7, the default of which is English. The OS's and Photoshop's interface languages are in English as well. Every application on my PC starts with English keyboard layout active, so when I launch a program I can start typing in it in English right away. But when it comes to using Photoshop, when I want to give a layer a name or type in something using the Type Tool, I have to switch to English keyboard first. And in fact I have to do this many times because the keyboard layout keeps reverting back at some point.

And, If I'm not mistaken, the same occurs in Illustrator as well...
Photo of Alex Jacobson

Alex Jacobson

  • 5 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of David

David, Official Rep

  • 2701 Posts
  • 361 Reply Likes
Howdy Alex,

Something doesn't sound right with your setup or description.  By default, Photoshop assumes that the keyboard is in the same language as the application.  So if your app is English, your keyboard should be too.  Further, the Photoshop installer defaults to match the OS language, so that if you're installing PS on a (for instance) Swedish OS, you'll get a Swedish PS unless you specify otherwise.

Are you using same utility or app to switch languages?  Because, if not, what you're describing shouldn't happen -- and hasn't in the last twelve or so years since we added these capabilities.

Thanks,
David
Photo of Alex Jacobson

Alex Jacobson

  • 5 Posts
  • 0 Reply Likes
Hi David.
I do realize all this may sound strange but the situation is exactly like I described it. I don't have any keyboard layout management utilities (in fact I hate those) and I believe this problem is haunting me since about CS6/2013. I'm voicing it only now because I wasn't typing in Photoshop much then. I did some googling back then though, and somebody was having the same issue. In order to fix the issue they were advised to set their preference for "language for non-Unicode programs" a.k.a. "System Locale"  to English, and I guess that eliminated the problem for that person. But I don't want to do that because after that I won't be able to read some non-English documents from my hard drive, and I hoped there may be a fix applied to Photoshop and Illustrator since clearly the problem is somewhere on their side....
(Edited)
Photo of David

David, Official Rep

  • 2701 Posts
  • 361 Reply Likes
Hi Alex,

I'm not sure what to tell you.

Photoshop has been fully Unicode compliant since, well, at least 15 or more years, long before we started the CS numbering.  In all that time (and more) I've never heard of a problem like the one that you're describing.  It almost sounds like you're running a hacked non-English version, which would then account for the problem that you're seeing.  Where / how did you buy your copy of Photoshop?

The only other scenario where this seems possible would be if you have some companion or side-car app or non-standard hardware which is creating the problem.

I know it might sound like I'm blowing you and your problem off, but I'm not.  I've been the "type guy" for at least the last 15 years and I've been the "international guy" even longer.  I usually run my PS (including copies under development) in a variety of different languages and on a similar variety of non-English OSes.  It's totally normal for me, for instance, to install German, French, and Russian PS on a Turkish OS and then switch between them as needed using both virtual and even physical keyboards (you should see my office!).  And, with nearly two decades of such experiences, I've never seen or heard of this issue.

I believe that you're having it, but I'm positive that there is an additional, NON-ADOBE element required to trigger this.

If you'd like, we could do a web-hosted screenshare so I could see what you are live and I could fiddle with your system settings to find the cause (and a solution!).

Thanks,
David
Photo of Alex Jacobson

Alex Jacobson

  • 5 Posts
  • 0 Reply Likes
Hacks have nothing to do with this as I have experienced the issue with the official Adobe distributions, in both trial and activated modes. As for my OS, again, I don't do anything special to it. It's the official Windows 7 Professional 64 bit English distributive. After installation I only add secondary Russian keyboard and set the system locale to Russian, that's it.

And honestly, I'm not sure about providing somebody a remote access to my computer, but I will consider that after checking if the problem still persists with system locale set back to English.
Photo of Alex Jacobson

Alex Jacobson

  • 5 Posts
  • 0 Reply Likes
Yep, looks like setting system locale to English hasn't changed anything...
(Edited)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13977 Posts
  • 1670 Reply Likes
Hi Alex, I'd be happy to have an agent work with you. I don't see an active membership under your Adobe ID (the email address you've used to post here). Is it possible it's under a different Adobe ID?
Photo of Alex Jacobson

Alex Jacobson

  • 5 Posts
  • 0 Reply Likes
Hi Jeffrey. I'm afraid my situation is rather complex and looking into it most likely won't give you much of an insight. Especially if this problem is unique, it would be easier and quicker for me (and everybody else) to just disable all keyboards except English when I'm working with Adobe applications and leave it at that. But thanks a lot for the concern guys!
Photo of David

David, Official Rep

  • 2701 Posts
  • 361 Reply Likes
Hey Alex,

Again, I worked with launching SIM GM more than a decade ago.  In all that time, we've never seen anything like what you're describing, except when incorrect language versions are involved.  I'd be happy to help you look into this problem, as I'm kinda curious about the cause, but it's your call.

Thanks,
David