Elements: Won't load up single photos; so slow

  • 2
  • Question
  • Updated 2 years ago
  • (Edited)
Hi everyone,

I am getting so so frustrated with this elements software. I bought it after reading lots of good reviews. I have a top of the range iMac with dual core. I bought it specifically to edit my photos.

I have shot some photos in raw. 

The software was so slow and really laggy so I deleted all files and changed the elements organiser preferences to turn off all media analyses as per recommendations from this site.

Now I have reloaded the photos. They load up quickly in 'grid' view but when I double click on a photo to load it up on full screen, it doesn't load up, just a blank screen with the circular icon whirring around in the bottom left corner but nothing loads up.

I really don't know what to do as it is getting so frustrating and I just cannot move forward. The iphotos software loads up photos effortlessly, how can a paid for photo programme not?!?

Any help would be greatly appreciated!

Regards,

Lukas
Photo of Lukas Kalinke

Lukas Kalinke

  • 9 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 2
Photo of Rens51

Rens51

  • 41 Posts
  • 6 Reply Likes
Hopefully someone may have a serious suggestion for you how to progress. I never had one experiencing the same problems on Elements 14 and Macbookpro, latest Siera operating system. The only thing I hear from Adobe is commercial emails to purchase Elements 15. No way. Also for me Apples Photos works well as Aperture did in the past.
Photo of Pete Green

Pete Green, Customer Advocate

  • 752 Posts
  • 147 Reply Likes
Hi Lukas, 

Sorry for the trouble with performance in Photoshop Elements. 

Which version of Photoshop Elements are you working with?
Have you tried uninstalling it, then reinstalling it to see if something went wrong during installation?

You might also go through these troubleshooting steps: https://helpx.adobe.com/photoshop/kb/basic-trouble-shooting-steps.html

Note, they're for Photoshop, but many of them are relevant for troubleshooting Photoshop Elements.

Let us know how it goes.
Regards
Pete
Photo of Lukas Kalinke

Lukas Kalinke

  • 9 Posts
  • 0 Reply Likes
Hi Pete

I have uninstalled and then reinstalled the software and uploaded the most recent update for my mac; still the same problem.

The photos do not load up from the grid mode. I have attached a photo of the screen I get when I double click on a photo.

Is there anything else I can do?

Thanks,

Lukas


Photo of Lukas Kalinke

Lukas Kalinke

  • 9 Posts
  • 0 Reply Likes
What should happen when you double click on a photo in the grid section in organiser? I presumed it should load up?
Photo of Michel BRETECHER

Michel BRETECHER, Champion

  • 1266 Posts
  • 268 Reply Likes
Double clicking is just for zooming out a selected thumbnail to fill the browsing space, leaving the left and right panels visible if they are open. Same effect as moving the zoom slider to max size.
It's not quite the same as 'full screen', available with the view menu or shortcut F11.

What's not clear for me is what really happens in your case. I assume you are seeing the small thumbnail when in grid view. Do you get a small question mark icon on that small thumbnail? That would mean that the file is 'disconnected' (not in the original location on your drive). The small thumbnail (max 240 x360 pixels) is stored in the catalog and available, but the file itself is not found and available for full display.
If you are selecting a raw file which is recognized in your Elements version, then the raw file is opened, converted with edits applied and finally displayed. Can take several seconds for a single file.
When you select such a raw file and click on the 'Edit in elements' icon on the bottom bar, does the raw file appear in the ACR raw conversion dialog?
Another question: what is your display type? I have read that there are a few problems with 5k displays.
Photo of Lukas Kalinke

Lukas Kalinke

  • 9 Posts
  • 0 Reply Likes
Hi Michel,

Thanks so much for the advice, I am away for work for 10 days but will check all the above and get back to you on my return, 

Best wishes,

Lukas 
Photo of Lukas Kalinke

Lukas Kalinke

  • 9 Posts
  • 0 Reply Likes
Hi Michel,

In my case, I can see the thumbnails fine when in grid view. When I double click on a photo, I see a large grey screen with a small question mark in the middle of it. Is this normal? Im still unsure what double clicking is meant to do. 

Using full screen is working fine and is what I thought double clicking would do; ie. seeing the whole picture zoomed in; just as happens when you double click a thumbnail in another programme. 

When I click on a RAW file and click edit in elements; it comes up fine in elements.

My display type is 5k,

Again, thanks again for your help and support,

Lukas 

 
Photo of Michel BRETECHER

Michel BRETECHER, Champion

  • 1266 Posts
  • 268 Reply Likes
Lukas,
I don't have a Mac, but your description seems to confirm that there is really a bug to display a single image with the double click on the thumbnail for a 5k display. Your tests do show that the question mark has nothing to do with the question mark used to indicate missing files.
Photo of Lukas Kalinke

Lukas Kalinke

  • 9 Posts
  • 0 Reply Likes
Ok, thanks Michel. 

Is there anything I can do about this bug? Should I make adobe aware? 

I had another question about the pictures folder. 

I am getting a bit confused about the role of the 'pictures' folder. I have imported all my files from iphoto by exporting them to a folder on my desktop and then importing that as when i did it 'in bulk', there were duplicates.

On the home page, there are my folders on the left hand side viewed in a tree format.My Pictures folder at the top of the list of folders is empty and all my photos sit under the headings Macintosh>Users>Lukas>Desktop>Exported photos.

 My questions are

  • are these files now imported as when I right click on the folder it states, "import media". When I click import, it just creates duplicates. 
  • Also, Im not sure why the Pictures folder is empty? It doesn't make sense that these files are not in my pictures folder as they are my pictures!!
  • If I then move them to be in the Pictures folder, that seems to duplicate them all.

 

Many thanks for your help,

 

Regards,

 

Lukas

Photo of Michel BRETECHER

Michel BRETECHER, Champion

  • 1266 Posts
  • 268 Reply Likes
"Is there anything I can do about this bug? Should I make adobe aware?"
Adobe is aware you have a problem, see the answer by Pete Green. That does not mean they have been able to reproduce the bug or find a solution/workaround.

What happens if you move the zoom slider on the bottom right slightly to the left? Does ist show two images side by side?

About the 'Pictures' folder what I can say is that in Windows, it's a kind of alias or shortcut to locate more easily the real folder in your user master folder. It looks like it's the same in your Mac OS. That means that there is no duplication, only two different ways to access the long path to the real location of your files. The organizer shows the real, physical location, not the alias.


Photo of Michel BRETECHER

Michel BRETECHER, Champion

  • 1266 Posts
  • 268 Reply Likes
Another post in the user to user forum:
https://forums.adobe.com/inbox
Photo of Lukas Kalinke

Lukas Kalinke

  • 9 Posts
  • 0 Reply Likes
Thanks Michel,

Now when I double click on photos, the whole image comes up as it should do; perhaps the bug has been fixed.

The next problem; I have tried importing from apple photos and there are just tons of duplicate photos. I am not sure why this is. I have looked online and this seems to be a common problem with Macs. 

There doesnt seem to be anyway around this apart from exporting the photos to a folder to the desktop and then importing from there. Then the pictures are not stored in the pictures folder, rather under Macintosh --> Users -->Name --> Desktop 

This is a bit disappointing as it means duplicating all the photos to a different folder then moving them across,

Are you aware of this problem?

Many thanks,

Regards,

Lukas 
Photo of Lukas Kalinke

Lukas Kalinke

  • 9 Posts
  • 0 Reply Likes
Hi Pete and Rens,

Thanks for your responses. It is photoshop elements 15 on the top of the range imac.

I havent tried reinstalling it but will do. 

It isnt even loading up a raw file to single screen; it just seems to get stuck loading it.

I will go through the troubleshooting steps above and let you know if reinstalling it fails,

Many thanks

Lukas