Why won't LR5.5 open after updating to it?

  • 1
  • Question
  • Updated 4 years ago
I have updated my Lr from 5.4 to 5.5 this morning via the cloud helper app. I am now unable to run LR at all.
My specs are
Windows: Microsoft Windows 7 Ultimate, 64Bit
Memory (RAM): 24 GB
Motherboard: ASUS P6T SE
CPU Info: Intel Core i7 CPU 920 @ 2.67GHz
Display Adapters: NVIDIA Quadro K2000
Monitors: 2x; NEC MultiSync LCD2690WUXi2 1920 x 1200, Eizo CG277 2560 x 1440,
At this point, I have been able to run the latest Bridge, ACR and CC 2014.
I also notice that while I was able to select LR5.4 in the cloud helper app to be updated, it is no longer displayed in the helper app.
Any ideas?
Photo of John Murray

John Murray

  • 21 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 1
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2611 Posts
  • 333 Reply Likes
Many people have this problem, both on Macs and PCs.

The fix from Adobe is to uninstall the CC installed LR 5.5 and then download and install the standalone version of LR 5.5, which supposedly will pick up the licensing from the previous CC version.

This process worked on one of my computers, but on the other it asked for a serial number. I was able to find the LR 5 (CC) serial number in my list of projects at adobe.com under Manage Account, after I logged in.

See the standalone install links on the Correct Answer near the top of this thread:
https://forums.adobe.com/thread/1499624
Photo of John Murray

John Murray

  • 21 Posts
  • 0 Reply Likes
Thank you very much for this. It has indeed resolved my issue. I appreciate your assistance.