Why does my computer say doesn't recognize "jpg" when I open Elements 8 - but does with other photo software?

  • 1
  • Question
  • Updated 5 years ago
  • (Edited)
I recently had to reinstall PSE 8. I open the program by clicking on an image on my computer I want to edit. I get a blank, black window. I look at the "File" meno in the task bar and it has a drop down list of "recently uploaded images", yet when I click on any of them, nothing!

I am also getting a message (but only when attempting to use PSE 8) that the computer doesn't recognize file extension "jpg"! I have other software photo programs and they all work just fine.

I just uninstalled and reinstalled PSE 8 again today, thinking that something might have gone awry in the last install. Nothing, same old blank screen. I tried to drag and drop, tried double clicking the image and tried uploading image from File=>Open. Nothing.

Yesterday I got a new error message, per the attached - and that is why I decided to uninstall and reinstall today.

Photo of Velma Sampson

Velma Sampson

  • 2 Posts
  • 0 Reply Likes
  • sad

Posted 5 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
Sounds like your registry entries got corrupted, so the OS doesn't realize that Elements can open JPEG images.
Photo of Velma Sampson

Velma Sampson

  • 2 Posts
  • 0 Reply Likes
Thanks Chris. Seems rather strange because I am uploading it to a 'new' computer - i.e. a computer that simply had Windows 7. I had it at the "doctors" - and that is why I am reinstalling all software.

Don't understand if that is the case why the computer picks up jpgs for other photo software?

How would I check for 'corruption' on the off chance...you are correct :-)?