Photoshop CS 5.5: Color profiles do not work correctly on a dual monitor display

  • 1
  • Problem
  • Updated 6 years ago
  • (Edited)
I'm using Photoshop CS5.5 on 64 bit Windows 7. My computer is quite a beast: a Dell T7500 workstation with a Quadro 4000 graphics card and dual monitors. I've recently purchased a i1 Display Pro colourometer and profiled both my screens. Looking at my Windows colour preferences, it appears each screen has it's own profile associated with it and in many of my other applications, the images are profiled properly on each monitor.

When I bring an image into Photoshop on my main screen, it is automatically adjusted correctly using the correct colour profile for that display. When I move the image over to my second display it also appears to be adjusted correctly. However, when I release the mouse (and the drop shadow appears on the image) the profile seems to disappear and the image changes contrast and saturation. Click on the image again and move it about a little and the image appears to be colour corrected properly.

I've tried switching on/off the OpenGL settings and other tweeks but this colour shift on mouse click still occurs. Is this a bug with Photoshop? It's obviously reading the colour profile before I take my finger off the mouse and it's loosing it after I release it.

For some reason, profiles are not being applied properly on second monitors and for people requiring professional results, this needs to be addressed as a matter of urgency! This issue has been reported by several people in forums and on the net, so I know it's not just me.

Any one with any advice? I do have a second graphics card I could dedicate to my second monitor. I wonder if this would fix the issue.

Thanks for listening

Steve.
Photo of Steven McCombe

Steven McCombe

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 7 years ago

  • 1
Photo of madra sexy

madra sexy

  • 1 Post
  • 0 Reply Likes
Preferences-Performance-Open Gl Drawing(enabled)-Advanced-Debugging-Color Matching (off) worked for me.

Don't ask me the theory!!!!!!