Photoshop CS6: Showing some random pixels/squares over canvas when I zoom in (macOS 10.14)

  • 2
  • Question
  • Updated 4 months ago
  • (Edited)



It looks find when I export the picture, I think something wrong with displaying. Mac 10.14 PS CS6.

Thanks for answering....
Photo of Alicia Liu

Alicia Liu

  • 5 Posts
  • 0 Reply Likes

Posted 5 months ago

  • 2
Photo of Dave S

Dave S

  • 16 Posts
  • 5 Reply Likes
The first question I would ask is, "does this blocking occur in any other application?" if yes then you have a graphics card/LCD screen/ Graphics driver issue. If the answer is no and it only occurs in PS then possibly there is something wrong with the graphics card or drivers. Did you check the Adobe's PhotoShop approved graphics cards and is yours on the list?

https://helpx.adobe.com/au/photoshop/kb/photoshop-cc-gpu-card-faq.html

Other things to try, does the issue still occur if you switch off the GPU in PS preferences? Edit/Preferences/Performance/Graphics Processor Settings/Use Graphics Processor

Has this started occurring just after a system or GPU driver update, if so, roll the driver back.

Last resort, check out Louis Rossman's YouTube channel to see if this is a common error with Macs
https://www.youtube.com/user/rossmanngroup/videos

Hope something helps you


Photo of Alicia Liu

Alicia Liu

  • 5 Posts
  • 0 Reply Likes
Thank you very much. It only occurs in PS. It occurs even I close/open the graphic processor. I will check on those websites..
Photo of Dave S

Dave S

  • 16 Posts
  • 5 Reply Likes
Hey Alicia, I just noticed that you stated PS CS6, that is quite an old version now and there have been quite a few new versions, perhaps there is an interface issue with a modern GPU and CS6 and that is causing the problem?

There have been 7 new versions since CS6 

https://en.wikipedia.org/wiki/Adobe_Photoshop_version_history

Thanks
Photo of Alicia Liu

Alicia Liu

  • 5 Posts
  • 0 Reply Likes
ya probably, I am using CC now, its just that I miss my CS6 T.T thank u for reply anyway
Photo of David

David, Official Rep

  • 3169 Posts
  • 500 Reply Likes
Have you updated your video card driver?  Are you still encountering this problem?
Photo of Alicia Liu

Alicia Liu

  • 5 Posts
  • 0 Reply Likes
idk how to.. I'll search about it
Photo of David

David, Official Rep

  • 3169 Posts
  • 500 Reply Likes
Howdy Alicia,

You're running a pretty old application (CS6) on a very new OS (Mojave).  It wouldn't be very surprising for there to be a mismatch.  Generally, most software is supported on the currently shipping OS and the last major version.  We're talking eight or nine major releases in this case.  Unless there's something specific to this version that you need, you'll almost certainly be happier (with a more responsive app) if you upgrade.

Thanks,
David
Photo of Alicia Liu

Alicia Liu

  • 5 Posts
  • 0 Reply Likes
Yea I updated now. Thanks David.