Lightroom is not showing the face tags after the photo has been rotated

  • 2
  • Problem
  • Updated 2 months ago
  • Acknowledged
  • (Edited)

Hi, have been struggling to find an answer to my problem:

If i draw a face region or if a photo has already the data of the face region and i rotate it 90° and i remove the photo from lightroom and re-import, it won't recognize the facetags despite that the information is in the XMP.

*As long as the photo is horizontal (that is normal orientation), there is no problem, i can delete the photo from Lightroom and re-import and it wil recognize the face region with the person's name.

i have tried to edit xmp metadata in all sorts of ways with exiftool to see if that would fix the problem but havent' had any luck.

I would appreciate any help to fix this issue.-

UPDATE: I posted this issue in Adobe Forums https://forums.adobe.com/thread/2626690 and we got to the conclusion that it is A BUG, so if this is correct please this has to be solved.

Thanks.
Photo of Kevin Jaimes

Kevin Jaimes

  • 1 Post
  • 0 Reply Likes

Posted 2 months ago

  • 2
Photo of John R. Ellis

John R. Ellis, Champion

  • 4535 Posts
  • 1213 Reply Likes
I observe the same behavior for JPEGs but not raws.  In particular:

1. Select a photo with a tagged face.

2. Rotate it 90 degrees and verify the face tag is still present.

3. Do Metadata > Save Metadata To File.

4. Remove the photo from the catalog without deleting it from disk.

5. Import the photo into the catalog.

6. If the photo is a raw, the face tag is still present. If the photo is a JPEG, the face tag is absent.
Photo of Chinoy Gupta

Chinoy Gupta, Employee

  • 77 Posts
  • 35 Reply Likes
Thanks Kevin for reporting this and John for the investigation. I am also able to reproduce the issue with JPGs and have filed a bug to investigate it further.

Thanks,
Chinoy