Elements 2.0: Refuses to save edited photos

  • 1
  • Problem
  • Updated 2 months ago
  • (Edited)
Having used Photoshop Elements 2.0 for many years it has suddenly started to refuse to save any edited photographs saying it is because of a programme error. Any suggestions welcome.
Photo of Ron Arthur

Ron Arthur

  • 1 Post
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Robert Marcos

Robert Marcos

  • 1 Post
  • 0 Reply Likes
I know that is SUPER ANNOYING. It acts as though I cannot update an existing image and makes me go through more steps in order to save it again. Really screwed up my efficiency when updating 100 or more photos...
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13635 Posts
  • 1546 Reply Likes
Are you using Elements 2.0 still? What OS are you running on?
Photo of JEA


  • 175 Posts
  • 135 Reply Likes
Resetting the pse 2 preferences often resolves issues like those.

Press and hold the Shift+Command+Option keys just after starting the launch of  pse 2

On windows its Shift+Ctrl+Alt

(you have to be quick about pressing the keys or you won't get the following dialog)


Keep holding the keys down until you get a dialog asking if you want to Delete the Adobe Photoshop Elements Settings File


Press Yes

Photo of Edgar J Pereira Deshon

Edgar J Pereira Deshon

  • 1 Post
  • 0 Reply Likes
I tried this and it didn't work.
Photo of Steve Lehman

Steve Lehman

  • 491 Posts
  • 53 Reply Likes
Did you guys happen to see the bottom portion of that question?  

Posted 1 year ago

Even I have PSE 3.0 on an XP machine but I never use it.  I use PSE 4.0 on an old laptop and a portable scanner for my in-person customer interaction.  But, I have PSE 3, 4, 8, 10 and 14.  I have CS 2 and 6.  And I have Light Room programs.  If I had trouble with an older PSE I would get a new one.