Why am I paying for nothing?

  • 3
  • Problem
  • Updated 4 months ago
I am paying each month for Adobe Photoshop on Mac OS Catalina.  It does not work!!!!  It worked (after many, many months of not working) for a little while and now it doesn't work at all.  Why am I paying each month for this aggravation?
Photo of Robert Gavila

Robert Gavila

  • 3 Posts
  • 0 Reply Likes
  • Very, very, very, very, very angry. Very.

Posted 4 months ago

  • 3
Photo of David

David, Official Rep

  • 3602 Posts
  • 615 Reply Likes
What's not working Robert?  Are you encountering a bug or installation issue?  Let us know.

Thanks,
David
Photo of R Cassidy

R Cassidy

  • 8 Posts
  • 3 Reply Likes
I am surprised by all of the reports of non-working Photoshop.

I am using Catalina 10.15.3 on the following machine with no problems other than PS not opening multiple files sent from Lightroom (hopefully they will fix this one day!).

  Model Name: MacBook Pro

  Model Identifier: MacBookPro11,4

  Processor Name: Quad-Core Intel Core i7

  Processor Speed: 2.2 GHz

  Number of Processors: 1

  Total Number of Cores: 4

  L2 Cache (per Core): 256 KB

  L3 Cache: 6 MB

  Hyper-Threading Technology: Enabled

  Memory: 16 GB


Hope this helps someone.

Photo of Robert Gavila

Robert Gavila

  • 3 Posts
  • 0 Reply Likes
I now find that nothing happens when I run Photoshop on mi iMac with Catalina (i7 chip, 32 GB ram). I uninstalled Photoshop. I downloaded photoshop.installer.dmg. I run it. I get a dialogue box “Adobe Creative Cloud needed to resolve the problem, is missing or damaged. You can try to repair to fix the issue. If the problem persists, download and install the new copy from http://www.adobecreativecloudapp:”. The color wheel spins, I click “Repair”. Nothing happens. I do it all again. Same results.

I have work to do. I can’t have this unstable BS going on every time I start this useless, expensive program that’s.goid for nothing.
Photo of Robert Gavila

Robert Gavila

  • 3 Posts
  • 0 Reply Likes
“...good for nothing...”