Elements: Why all images have a question mark in elements

  • 1
  • Question
  • Updated 11 months ago
  • (Edited)
Photo of Kathryn Dawson

Kathryn Dawson

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Arshla Jindal

Arshla Jindal, Employee

  • 8 Posts
  • 1 Reply Like
Hi Kathryn,

Question mark on Images in Elements implies that the files are missing from their location on hard disk. This can happen either when you have changed the image location from outside the Elements Organizer or the file has been deleted, again from outside the EO.

To rectify this, go to File menu and select Reconnect > All missing files.

EO will try locating all your files on your hard disk and reconnect them in case they are present somewhere at new location.
You can also do this manually by double clicking the image and manually navigating to the image if you know it's location at your hard disk.

Please try this and provide your feedback.

Thanks,
Arshla
Photo of Michel BRETECHER

Michel BRETECHER, Champion

  • 1123 Posts
  • 235 Reply Likes
If you can right click on a missing thumbnail and that can display it, another reason might be the one in this paper:
http://psekb.blogspot.fr/2014/09/how-to-correct-hourglass-generic.html
Photo of Sandy Routh Boeshart

Sandy Routh Boeshart

  • 2 Posts
  • 1 Reply Like
I know this is an old post, but my elements 15 catalog just today shows ALL my thumbnails with a question mark. I've tried repairing and optimizing both and they did nothing. I have thousands of digital scrapbook things in this catalog and this would take me forever to double click on each one to get the question marks off. I don't understand why this happened. I so hope someone can help! Thanks!
Photo of Michel BRETECHER

Michel BRETECHER, Champion

  • 1123 Posts
  • 235 Reply Likes
Did you try my suggestion on the previous post?
It's important to know if the file are no longer where they were before (changes outside of the organizer) or if the thumbnail cache file is corrupted.
If you can update a single file with the right click and 'update thumbnail', it may be the latter, and the link I have given should help you to refresh the thumbnail cache.
If not, the files are no longer where they were before.
Photo of Sandy Routh Boeshart

Sandy Routh Boeshart

  • 2 Posts
  • 1 Reply Like
Actually I restarted my Mac and everything is good now. Thanks for replying though!