When importing from SD card with multiple folders, Lightroom import dialog ignores one of the folders

  • 1
  • Problem
  • Updated 11 months ago
Lightroom is ignoring some of the images on my SD card and will not let me see them in the import dialog box. As a result, it silently failed to import photos from the card. Even going back to that card now, the Import dialog box does not show the images or let me import them.

The SD card has multiple folders generated by cameras, structured like:

/DCIM/100CANON
/DCIM/103_PANA
/DCIM/104_PANA
/DCIM/105_PANA

The Canon folder is empty, the three Panasonic folders have lots of photos shot on a ZS100. 

The Lightroom import dialog box only shows the photos in the 104_ and 105_ folder and nothing from the 103_ folder. Even now if I try to import it, i cannot see and select photos from that folder in lightroom, even though they show up fine on the SD card in Finder. To import these images, I had to first copy them to my hard drive.

This is alarming! Now I need to go back over every SD card I used with the Panasonic ZS100 to make sure nothing else was silently ignored.

Versions:
Lightroom 6.12.
MacOS 10.12.6
Photo of Paul

Paul

  • 12 Posts
  • 2 Reply Likes
  • annoyed and worried

Posted 11 months ago

  • 1
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1215 Posts
  • 489 Reply Likes
Is it possible that this folder contains images that have been imported already? Lightroom won't import the same images twice.
Photo of Paul

Paul

  • 12 Posts
  • 2 Reply Likes
The images were not imported already.
Photo of Just Shot Me

Just Shot Me

  • 191 Posts
  • 48 Reply Likes
Using the same card in different cameras, Especially different makes of cameras but even in the same make of camera but different models, without formatting the card in each camera, is a VERY VERY BAD IDEA.
If you can afford multiple cameras you can afford multiple SD cards. One at least for each camera.
Sorry to be so blunt and sorry I don't have an answer to your original question.
Photo of Paul

Paul

  • 12 Posts
  • 2 Reply Likes
I gather that this is good advice in general. Ironically, given your comment, I discovered the missing images when I was about to format the card in a new camera but did a quick review in-camera first. The new camera was able to view the cross-camera cross-brand images no problem, so its especially confusing that Lightroom wasn't.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3429 Posts
  • 616 Reply Likes
I built a test card using the information provided and Lightroom 6.12 imported all images.  I am not able to duplicate.