What Causes Lightroom to Crash Immediately after Launch?

  • 1
  • Question
  • Updated 6 years ago
What may cause Lightroom to crash immediately after having been launched? Why does it run fine when started again immediately after having crashed?

When I switched to 3.5RC on Windows XP, Lightroom very often just started to build up some panels but then immediately crashed before any user interaction.

Every and each time, I simply tried again (as if that made sense with anything else but software), and Lightroom started and continued to work as normal. How is that possible? If there was a reason for LR to crash, why does it suddenly disappear?

Somewhat related: After changing to 3.5 final, it seems as if thumbnail refreshing in the grid mode has become slower. Is there a recommendation to delete preview folders when changing LR versions?

Maybe related: Is anyone from Adobe interested in a DNG file that has been corrupted by LR (99.9% sure about that because I normally don't use any DNG file related software other then LR and certainly cannot recall having done anything special to this very non-special file) to the extent that both LR and Picasa Photo Viewer choke on it, becoming slow and unresponsive. Neither can display the contents. Without having been able to resort to an original raw file backup, this image would have been lost.
Photo of TK


  • 531 Posts
  • 108 Reply Likes

Posted 6 years ago

  • 1
Photo of Dan Tull

Dan Tull, Employee

  • 172 Posts
  • 38 Reply Likes
Official Response
Usually intermittent crashers, especially that happen on an initial launch are timing issues. On a subsequent try, the disk cache makes launch go faster so the timing issue doesn't happen.

That said, if you see it intermittently and can set up Dr. Watson to save crash dumps, I'd be curious to look at one and try to diagnose it. This site has some fairly easy to follow instructions for setting this up:

As for the grid speed thing, I'm not sure off hand what might have caused it, but with the exclusion of version 1.1, we've avoided breaking the rule that dot releases do not change catalog or preview cache format, so there should be no need to nuke previews. There definitely shouldn't be a need to do so between the RC and final 3.5 builds.

Last, I would be curious to look at the damaged DNG. I won't bank on being able to figure out how it happened, but if it makes LR misbehave when it is opened that's bad regardless of how it got that way.

Thanks -- DT