Lightroom: What solutions exist to fix errors between Publish Services and Flickr?

  • 2
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
I post process my digital photographs in OS X 10.9.5 through LR 4.4 and for several years successfully published images to Flickr via Publish Services feature in LR. In the past month I have been unable to publish new images or modify images published in the Flickr catalogue. Instead, I received two error messages. The first stated:

Can’t update this collection [ie., the Flickr collection in Publish Services]:

An internal error has occurred: Error Domain=NSXMLParserErrorDomain Code=4 "Line 1: Document is empty
" UserInfo=0x600010866bc0 {NSLocalizedDescription=Line 1: Document is empty
}

Yahoo responded that it could not vouch for third-party plug-ins and concluded that this was an Adobe problem. Even so, the next message suggests that Yahoo is complicit in the failure.

After installing LR5 Trial Version and attempting again to use Publish Services, I received a second error message:

Can’t update this collection. Flickr API returned an error message (function upload, message Filetype was not recognised)

The file type of the images published on Flickr has remained unchanged. I am stymied. The blogs are filled with entries reporting these problems, many dating back several years. Yet I have found no certain solutions. I ask for your guidance in restoring the utility of this important LR feature. Thanks.

David Hawkins. Dec. 8, 2014.
Photo of David Hawkins

David Hawkins

  • 2 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 2
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 382 Reply Likes
I assume you are using the built-in (Adobe-provided) Flickr plugin.

If I were you, I'd try Jeffrey Friedl's Flickr plugin.

If both have the same problem, you know it's not just an Adobe Flickr plugin bug, and you could ask Jeffrey about it - maybe he'd fix pronto (and/or report problem to Flickr..). If Jeffrey's does not have the same problem, then this question can be changed to a bug report ;-}, and you've got a solution for the mean time..

R
Photo of David Hawkins

David Hawkins

  • 2 Posts
  • 0 Reply Likes
Rob: I took your advice and installed the plugin from Jeffrey Friendl. On this the fourth day after installation, the Flickr publish feature on my LR4 seems to be working without a problem. Thanks.
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 382 Reply Likes
I see this was changed to a problem report - good,

and marked "Solved" - bad.

I mean, the problem still exists with the Adobe Flickr plugin, which is the problem being reported.

I get that the user's problem is solved, in a fashion, but Adobe's problem with their Flickr plugin is still not solved, and if this bug is marked "solved" will it still be considered for fixing? - presumably not..