Weird blank space in LightRoom window

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
Since the buggy update last fall (2015.2?), my LR screen shows a white rectangle to the left side of the module names.  It's as if a section of the screen is missing. It goes away during the process of importing files, and is also a fixed size (i.e., if I resize the LR window the rectangle doesn't change size).  It doesn't affect any operations in LR, so I've been slow to ask for help, but the latest revs (I just loaded 2015.4) haven't fixed it.  I've attached two images - one showing the white rectangle and one showing it absent during the import process.  I'm running a mid-2014 Macbook Retina Pro with El Capitan.
Photo of burkemt

burkemt

  • 5 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of John R. Ellis

John R. Ellis, Champion

  • 3608 Posts
  • 938 Reply Likes
Try these two magic spells:

- Uncheck the option Preferences > Performance > Use Graphics Processor.

- Reset LR's preferences: http://www.lightroomforums.net/showth...

They fix a surprising number of issues in the user interface.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4173 Posts
  • 1497 Reply Likes
And if that doesn't do the trick, try right-clicking and choosing a default ID plate - I'm wondering if you have a custom ID plate with a font that isn't working, or a logo image that's missing.
Photo of burkemt

burkemt

  • 5 Posts
  • 0 Reply Likes
Thanks, guys - John's suggestion (i.e., magic spell) did the trick!  Which leads me to a follow-on question: does the "use graphics processor" option actually help my performance enough that I would notice if it were not enabled?  And thanks again to both of you for your quick responses.
Photo of John R. Ellis

John R. Ellis, Champion

  • 3608 Posts
  • 938 Reply Likes
That's interesting -- according to the lead developer, Lightroom restricts its use of the GPU to Develop mode. But there have been enough of these instances where disabling its use fixes the problem that the liberal sprinkling of the magic spell has been justified.

In general, you'd only notice a large improvement on 4K or 5K displays.  Otherwise, the general perception is that there isn't much gain to enabling the GPU.    
Photo of John R. Ellis

John R. Ellis, Champion

  • 3608 Posts
  • 938 Reply Likes
Also, on Windows, the general recommendation is to update your graphics driver. But you're on OS X, so that doesn't apply.
Photo of burkemt

burkemt

  • 5 Posts
  • 0 Reply Likes
Thanks, John.  I really appreciate the guidance.
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1428 Posts
  • 441 Reply Likes
Try turning back on the Preferences > Performance > Use Graphics Processor. I suspect the issue is some preference that reference some stale info.
(Edited)