Watermark shadow doesn’t show when printing to jpg file

  • 1
  • Problem
  • Updated 2 weeks ago
  • Acknowledged
I created a white text string with a dark shadow in the LR watermark editor. When printing to a jpg file, the shadow did not appear although the text appeared correctly (flat - no depth). I then tried to print to a printer, selecting a PDF printer in the printer dialog box (MacOS 10.14), the shadow appeared correctly in the pdf file. I tried various combinations of printing options, and decided there is a bug in printing watermarks with shadowed text to a jpg file (print to file). I printed the image to a pdf file, imported to photoshop, the saved as a jpg file to get around the problem.
Latest version of LIghtroom Classic (2020) as of 2020/02/11.
Photo of Lance Beden

Lance Beden

  • 3 Posts
  • 0 Reply Likes
  • frustrated.

Posted 2 weeks ago

  • 1
Photo of Mayuri Jain

Mayuri Jain, Employee

  • 84 Posts
  • 30 Reply Likes
Hi Lance,

Thanks for taking out time to raise the issue. We will investigate and keep you posted for further updates.

Regards
Mayuri
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 6717 Posts
  • 1516 Reply Likes
Hello Lance,

Lightroom doesn't have a version called '2020'. Could you please go to Help>System Info... and get us your installed Lightroom version number? (likely 9.2)
Photo of Lance Beden

Lance Beden

  • 3 Posts
  • 0 Reply Likes
Lightroom Classic version: 9.2 [ 202001311240-2d026470 ]License: Creative Cloud
Language setting: en-US
Operating system: Mac OS 10
Version: 10.14.6 [18G2022]
Application architecture: x64
Logical processor count: 12
Processor speed: 2.2 GHz
SqLite Version: 3.30.1
Built-in memory: 32,768.0 MB
Real memory available to Lightroom: 32,768.0 MB
Real memory used by Lightroom: 3,230.5 MB (9.8%)
Virtual memory used by Lightroom: 10,944.9 MB
Memory cache size: 1,225.8MB
Internal Camera Raw version: 12.2 [ 384 ]
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 80MB / 16383MB (0%)
Camera Raw real memory: 81MB / 32768MB (0%)
Displays: 1) 3840x2400

Graphics Processor Info: 
Metal: AMD Radeon Pro 560X


Photo of Robert Somrak

Robert Somrak, Champion

  • 529 Posts
  • 178 Reply Likes
I can duplicate this behavior in Lr9.2 and macOS 10.14.6

Watermark in watermark editor


Print to JPG


Save to PDF in print module Printer Menu

As you can see there is a shadow in the "Print to JPG" but it is not the correct size/offset/opacity. In the "Save to PDF....." it is the same as in the Watermark Editor.
Photo of Robert Somrak

Robert Somrak, Champion

  • 529 Posts
  • 178 Reply Likes
To add to the above comment, the actual paper print has the correct Watermark shadow so the issue is only for "Print to JPG"
Photo of Lance Beden

Lance Beden

  • 3 Posts
  • 0 Reply Likes
This is my problem:



Photo of Robert Somrak

Robert Somrak, Champion

  • 530 Posts
  • 178 Reply Likes
I would say that this is definitely a BUG
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 6717 Posts
  • 1516 Reply Likes
That's why it is marked acknowledged above...

Mayuri has written a bug.
Photo of Robert Somrak

Robert Somrak, Champion

  • 530 Posts
  • 178 Reply Likes
Thanks for the update Rikk.  I forgot to look at the top.
Photo of Mayuri Jain

Mayuri Jain, Employee

  • 84 Posts
  • 30 Reply Likes
Hi,

I have already logged a bug for the same.

Thanks
Mayuri