Lightroom CC: Watermark feature is not showing on photos when sharing and downloading, ONLY when downloading in the album I have created , not in the link

  • 1
  • Question
  • Updated 3 days ago
  • Answered
  • (Edited)
Watermark feature is not showing on photos when sharing and downloading, ONLY when downloading in the album I have created in the private account, not in the share link.
Photo of Idan Cohen

Idan Cohen

  • 1 Post
  • 0 Reply Likes
  • Disappointed

Posted 5 months ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5595 Posts
  • 1184 Reply Likes
Would it be possible for you to give us step-by-step instructions for reproducing what you are seeing?
Photo of Jason Hesse

Jason Hesse

  • 2 Posts
  • 0 Reply Likes
please see my response
Photo of Jason Hesse

Jason Hesse

  • 2 Posts
  • 0 Reply Likes
I have the same issue
When sharing photos to friends without the app, on the web; photos do not have copyright watermark. Huge problem.

In the mobile app: click ". . . " to the right of the album, click "Share & Invite", under "link Access" set to "Anyone Can View", under "Link Settings" set "Allow Downloads" to on. Copy share link "https://adobe.ly/xxxxx", open private browser, paste share link, view public album, select any picture to open it individually (still in browser), select again, select download, hold select, select "save image".
Image is saved to camera roll without watermark. When sharing photos to friends without the app, on the web; photos do not have copyright watermark. Huge problem.

Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5593 Posts
  • 1182 Reply Likes
Watermarking of this type has not yet been implemented in the Lightroom ecosystem. 

This would fall into the realm of a feature request. There is a similar request here where you can add your votes and comments: Lightroom CC for web: Ability to Watermark images 
Photo of Freddy Leyton

Freddy Leyton

  • 1 Post
  • 0 Reply Likes
I got the same problem