Lightroom Classic: Warning before Lightroom applies multiple edits

  • 2
  • Problem
  • Updated 7 months ago
  • Solved
  • (Edited)
Lightroom doesn't behave the same as most other Windows programs, in that it's easy to have more than 1 photo selected and not realize it. For example, in Windows Explorer if you select all photos and then click on any one photo ONLY that photo will be selected. In the Grid View in Lightroom if you select all photos and then click in the photo part of a cell all the photos will remain selected. More than once I have applied edits to many photos when I think I'm only editing one.
It would be nice if a warning appeared saying "You are about to apply changes to 350 photos. Continue"?.
It would have the usual "Don't warn me again" checkbox if you don't want to see the warning again.
Photo of FlashAbercrombie

FlashAbercrombie

  • 6 Posts
  • 2 Reply Likes

Posted 7 months ago

  • 2
Photo of Sarah

Sarah

  • 7 Posts
  • 2 Reply Likes
Great idea! create idea
Photo of Steve Gandy

Steve Gandy

  • 109 Posts
  • 36 Reply Likes
Turn off the auto syncing feature and you will only be editing the main selection. Most only turn this on when they actually want edits to be synced across a selection of images. Sounds like you turned it on by mistake maybe?
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1165 Posts
  • 474 Reply Likes
Try resetting your preferences, because this is not how Lightroom should work: https://www.lightroomqueen.com/articl...
Photo of FlashAbercrombie

FlashAbercrombie

  • 6 Posts
  • 2 Reply Likes
Thanks, I'll give that a try.
Photo of Rick Spaulding

Rick Spaulding, Champion

  • 564 Posts
  • 221 Reply Likes
Yup!! You beat me to it! 

One other thing... By your pictures it looks like you are in the Develop module when you make the edit but I have to ask...
If you are in Grid view with multiple images selected, pressing the "V" key for black and white will change all selected images. In the Develop module it should only change one when Auto Sync is off. (sorry for being so redundant) 

So... to be clear, you are not in the Grid view when you try this, correct?

And... sometimes weird behavior can be remedied by resetting Lightroom Preferences. 
Photo of FlashAbercrombie

FlashAbercrombie

  • 6 Posts
  • 2 Reply Likes
Yes, I was in the Develop Module when I made the edits.

I reset the preferences (renamed the pref files) and it's now working as it should.

I guess I'm a little older and little wiser about Lightroom weirdnesses now. :)

Thanks so much for all the help and your patience, Rick and Johan!
Photo of Rick Spaulding

Rick Spaulding, Champion

  • 564 Posts
  • 221 Reply Likes
Excellent! Glad it worked out!