Virtual Copies not added to Collection when created in Collection

  • 1
  • Problem
  • Updated 3 weeks ago
Since updating to LRC CC 8.0, I've noticed that if you create a Virtual Copy within a collection or album, the Virtual Copy is not added to that collection/album.

You must go to the "All Photographs" album in order to see the Virtual Copy. This really breaks up a workflow and occurs in both Library and Develop views.

The app also does not present any UI that the Virtual Copy has even been created.
Photo of Trevor

Trevor

  • 18 Posts
  • 4 Reply Likes

Posted 4 weeks ago

  • 1
Photo of Carlos Cardona

Carlos Cardona

  • 323 Posts
  • 66 Reply Likes
That’s been like that for a while, you just noticed it in LR 8. Really annoying,right?
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1600 Posts
  • 648 Reply Likes
No, that has not been like that for a while, at least not on my Mac version of Lightroom Classic 8. If I create a virtual copy while I am in a collection, that virtual copy shows up in that collection. Just like it should. Check that you have not filtered on original files.


(Edited)
Photo of Geoff Culbertson

Geoff Culbertson

  • 12 Posts
  • 2 Reply Likes
I've just noticed this as well. When you select attributes while in a collection, you can click the button and it shows on screen that masters & virtual copies will be displayed, but no virtual copy appears. Return to All photographs and the virtual copies appear. What is even stranger is that when in a collection you select the virtual copy only button, the photo I have made a virtual copy of does not appear. LR Classic v. 8.0
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1599 Posts
  • 647 Reply Likes
"When you select attributes while in a collection, you can click the button and it shows on screen that masters & virtual copies will be displayed, but no virtual copy appears."

Which button? The buttons I show in the screenshot are for either originals or virtual copies. There is no button that shows both (but you can click both buttons).
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1600 Posts
  • 648 Reply Likes
Mac or Windows?
Photo of Marsha Levine

Marsha Levine

  • 29 Posts
  • 5 Reply Likes
I have windows 10. When I try to create a virtual copy from an image in a collection, it does it. No problem.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1134 Posts
  • 366 Reply Likes
It's working properly on my Windows 7 system with LR 8.0 as well.