View>Snap (toggle) overridden by the Snap To>submenu. Must always set to None

  • 1
  • Problem
  • Updated 3 years ago
Regardless of whether the Snap toggle is checked or unchecked as long as there are items in the Snap To-sub-menu snapping will occur.

I always have to uncheck all Snap To-items (None) for snapping to stop happening despite the Snap toggle being unchecked.

This has been the case for as long as I can remember using Photoshop.

For repro: Have a sub-item such as Document Bounds or Layers checked in Snap To> and the Snap-toggle above it unchecked.

Make a lasso selection of some pixel data. Hold down control while Lasso Tool being the active tool and cut-drag the selected pixels around and snapping will occur despite Snap toggle being unchecked.

If you make the selection and then switch to the Move Tool and move the selected pixels around then this will not occur.

It seems that when you ctrl-move a selected pixel area around while still on the Lasso Tool the Snap toggle gets neglected.
Photo of Erik Jakobsson

Erik Jakobsson

  • 16 Posts
  • 1 Reply Like

Posted 3 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
The control key is a toggle for the snap behavior -- so if snap is off, pressing control makes it snap; and if snap is on, control makes it not snap.
Photo of Erik Jakobsson

Erik Jakobsson

  • 16 Posts
  • 1 Reply Like
Oh really? I feel uninformed now ;-) Can this feature be hotkeyed away? (since ctrl already modifies most tools so one might not want it to do this)
Photo of Erik Jakobsson

Erik Jakobsson

  • 16 Posts
  • 1 Reply Like
How about adding a setting in Preferences to turn this feature on/off entirely?

It could be checked to 'on' by default so no one would be surprised.

It is the #1 (if not the only, and that should say something (thumbsup)) frustration I have with using PS on a daily basis.

Best regards