Lightroom CC: Very very slow migration from Lightroom Classic

  • 1
  • Problem
  • Updated 1 month ago
  • Solved
  • (Edited)
Since 3 weeks I'm trying to migrate my LR Classic catalog to LR CC on my iMac. I have 80'000 photos at around 800GB. The catalog migration of the first 40000 photos went at reasonable speed within 1 day - but since the last 3 weeks it has only migrated additonal 17000 photos. And this is only migrating the catalog. Uploading the photos to the cloud is even slower - only around 3500 photos have been uploaded to the cloud during the migration process.
I have stopped and restarted the migration process a couple of times by closing LR, but without improvement.
I'm considerably frustrated about this migration and really need help before I trash all this.
Photo of Carsten Horst

Carsten Horst

  • 7 Posts
  • 1 Reply Like
  • frustrated

Posted 4 months ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5544 Posts
  • 1166 Reply Likes
What is the free space on the disk where your default Pictures folder is located?
Photo of Carsten Horst

Carsten Horst

  • 7 Posts
  • 1 Reply Like
I found the root cause of the problem: I stored my photos on my NAS and that slowed down the process dramatically. I moved all photos to a local attached HD and re-started the migration process. The migration completed after one day and the sync of all photos was completed after 3-4 days.
So finally a success of the migration.

Now I realise a different problem:
All photos are migrated, but not all photos are associated to their corresponding album in the web/iOS version. Some albums are empty, others only contain a subset of the photos they should contain. In LR CC Desktop on my Mac everything is correct.

Is there anyway how I can reforce a sync of the album association to the cloud or any other efficient way of re-assigning the photos to their albums?
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5506 Posts
  • 1157 Reply Likes
Sounds like things haven't synced fully yet.  If you click the cloud icon in the upper right on the Desktop software does it say syncing is in progress or is it complete?
Photo of Carsten Horst

Carsten Horst

  • 7 Posts
  • 1 Reply Like
It says sync is complete.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5506 Posts
  • 1157 Reply Likes
Please provide the following:

Desktop App - Count of All Photos:
Mobile App(s) - Count of All Photos:
Log into your Account at http://lightroom.adobe.com.  Web App: Count of all photos: 

Then: 
Take a screenshot of your Albums list from LIghtroom Web

Then go to the Desktop App and take a screenshot of your albums list. Post both here. 
Photo of Carsten Horst

Carsten Horst

  • 7 Posts
  • 1 Reply Like
Desktop App: 80463
Web App: 80463
Mobile App: 80463

The album list is very long, I attached a screenshot of small part. One album I'm looking at e.g. has 141 photos in the desktop app and only 60 in the web / mobile app.

(Edited)
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5506 Posts
  • 1157 Reply Likes
Carsten, I've heard back from the engineers and they tell me your issue is known but not common. We have a fix coming in an upcoming release. 
Photo of Carsten Horst

Carsten Horst

  • 7 Posts
  • 1 Reply Like
Hi Rikk, thanks for your feedback. Is there any outlook when this fix will be available and if I would need to re-do the whole migration or whether this can be applied to my current set?
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5506 Posts
  • 1157 Reply Likes
No ETA on the fix - unfortunately. 
On the plus side, is when implemented it should fix itself without a complete redo. 
Photo of Carsten Horst

Carsten Horst

  • 7 Posts
  • 1 Reply Like
Thanks, sounds promising. Looking forward to the fix release !!
Photo of Carsten Horst

Carsten Horst

  • 7 Posts
  • 1 Reply Like
Hi, I just want to confirm that it seems that the sync issue has now been resolved with the latest version of LR CC - released yesterday (i.e. 20190502-0902-47ed471).