Very poor performance usig LR on Majave

  • 3
  • Problem
  • Updated 8 months ago
Currently it hardly is possible to work with LR at all...
LR performes very slow, is hanging etc...

Sometimes it works ok... I don ́t want to say "good" - and then it slows down dramaticaly in the same Library.

Especially using the brush is a pain. I have to use it in 1:1 view quite often. When painting someting with the brush sometimes it ́s quite ok - sometimes I have to wait several seconds before seing what I have painted...

Export to jpg - somtimes it ́s fast  - somtime very slow.
Yestertay e.g. I have exported developed 53 RAW (Sony ARW) in web Quality (2048px, 80% quality, 1mb max) to my Desktop - this took around 30 Minutes!!!
A few days earlier I had to wait a few minutes to export around 150 pictures...

No Idea what to do to resolve that issue...

My Specs:
MacPro, 6 Core Xenon, 32GB RAM, AMD D500
Mojave most current official version (no beta)
Most current LR from Adobe Subscription

My Library is located on the local SSD. No matter if using a 10k photos library or a just 100 photos library.
Photo of Guido Weerenbeck

Guido Weerenbeck

  • 8 Posts
  • 1 Reply Like
  • very frustated...

Posted 8 months ago

  • 3
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 6001 Posts
  • 1322 Reply Likes
Guido,

Thank you for the information. Could you please provide the following?

Help>System Info... Installed Lightroom version number?
Mac>About this Mac: Mojave version number?

Then go to Preferences>Performance and tell us if your GPU option is checked or not.
Photo of Guido Weerenbeck

Guido Weerenbeck

  • 8 Posts
  • 1 Reply Like
Hi Rikk,

LR says:

Lightroom Classic-Version: 8.1 [ 1200465 ]
Lizenz: Creative Cloud
Spracheinstellung: de-DE
Betriebssystem: Mac OS 10
Version: 10.14.3 [18D42]
Anwendungsarchitektur: x64
Anzahl logischer Prozessoren: 12
Prozessorgeschwindigkeit: 3,5 GHz
Integrierter Speicher: 32.768,0 MB
Für Lightroom verfügbarer phys. Speicher: 32.768,0 MB
Von Lightroom verwendeter phys. Speicher: 1.229,1 MB (3,7%)
Von Lightroom verwendeter virtueller Speicher: 3.761,0 MB
Cache-Speichergröße: 18,8MB
Interne Camera Raw-Version: 11.1 [ 112 ]
Maximale Anzahl Threads, die Camera Raw verwendet: 5
Camera Raw SIMD-Optimierung: SSE2,AVX
Virtueller Speicher in Camera Raw: 142MB / 16383MB (0%)
Physischer Speicher in Camera Raw: 144MB / 32768MB (0%)
Monitore/Anzeigegeräte: 1) 1920x1200, 2) 1920x1200

Informationen zum Grafikprozessor:
Metal: AMD Radeon HD - FirePro D500


About this Mac also tells me: v10.14.3


Currently GPU Option is NOT checked.
I have tried to check it recently - but I did not realize any difference.
While having performace problems I tried to check it and LR became a bit faster in 1:1 view - but for a short time only... After a short time LR became very slow again.

I hope it helps...

Guido
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 6001 Posts
  • 1322 Reply Likes
GPU enabled primarily affects Develop module edit performance with one exception - lagging Adjustment Brush strokes (which you called out in your OP) . If lots of brushing is required by your editing style you will be best served to leave it off. If you would prefer other parts of Develop to take priority then leave it checked.

GPU does not affect Import/Export times to any great extent. 

One thing Mac users can do to improve performance in this area is to make sure their Mac hasn't been running for weeks or months without a restart.  If you restart, wait 5 minutes, launch Lightroom and wait 5 minutes, and then attempt an export or import is it still slow?
Photo of Guido Weerenbeck

Guido Weerenbeck

  • 8 Posts
  • 1 Reply Like
Hi Rikk,

sorry for the late reply - was quite busy.

I have restarted my Mac several times and indeed LR (and PS) are faster then - but only for some minutes. Then they slow down again.

So yesterday I decided to perform a "clean install" of my mac... No Backup restores etc... complete clean.

Guido
(Edited)