Photoshop: CS6 keyboard shortcuts swapped (keyboard layout mistake)

  • 1
  • Problem
  • Updated 9 months ago
  • (Edited)
Photoshop CS6 Extended vertauscht die tasten "Z" und "Y" miteinander!!! Soll heissen wenn ich den Shortcut Z drücken möchte muss ich Y drücken und umgekehrt!!! Bitte um Lösung ?!
Photo of Karsten Schreiber

Karsten Schreiber

  • 3 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
>> translated

swapped keyboard

Photoshop CS6 Extended swapped the keys "Z" and "Y" to each other! Do you mean if I want to press the shortcut Z I have to press Y, and vice versa! Please solution?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
Photoshop doesn't control the keyboard -- it just gets the information on what was pressed from the OS.

Which OS version are you using?
And have you accidentally changed your keyboard layout? (way too easy to have happen on MacOS)
Photo of Karsten Schreiber

Karsten Schreiber

  • 3 Posts
  • 0 Reply Likes
My OS is Windows 7 Ultimate and I not changed my keyboard layout ! But if i try the Shortcut "Y" or "Z" sometimes changed Photoshop the keyboard layout: for example Shortcut in "Z is Y" and "Y is Z" and so go on ?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 764 Reply Likes
Again: Photoshop cannot change the keyboard layout. Photoshop just gets key press data from the OS. If something has changed the layout, it has happened outside of Photoshop.

Now, you can change the shortcut assignments under Edit->Keyboard Shortcuts. But it sounds like you're saying the actual keys changed, not just the shortcuts.
Photo of David

David, Official Rep

  • 2682 Posts
  • 359 Reply Likes
Howdy Karsten,

Chris is correct; Photoshop can only respond to the keyboard which your Operating System has defined. There are users all over the world who, for instance, have a physical keyboard in English, but using the keyboard layouts for their OS (such as Win7) are able to type in German, French, Japanese, Russian, Arabic, etc.

You are EITHER running the German version of Win7 OR running the English version of Win7 with a German keyboard layout enabled. On Win7, you can change your keyboard simply by going to Control Panel > Change Keyboard or other input methods (under Clock, Language, Region) > Keyboards and Languages tab > click Chance keyboards button. Just choose the one(s) you want and click Ok. Then, you will be able to switch between then via the control in the bottom right of your Task Bar.

Thanks,
David
Photo of Karsten Schreiber

Karsten Schreiber

  • 3 Posts
  • 0 Reply Likes
Thanks for your help, my Keyboard Layout is German!!! So i do not understand why changed it? But now I Updated my OS on Windows 8 Pro and it gives no Problems!!! :-)
Photo of Matei Stefan

Matei Stefan

  • 3 Posts
  • 0 Reply Likes
I'm having the same problem: Z and Y switched today ONLY in Photoshop, out of the blue. When I type here or in any other document the Z and Y are working properly.

... but in Photoshop the two keys are switched. The UNDO is now working with Ctrl Y. The Type tool sees Y as Z as well, and vice-versa. It's very annoying.
(Edited)
Photo of David

David, Official Rep

  • 2682 Posts
  • 359 Reply Likes
Howdy Matei,

You've almost certainly accidentally switched your virtual keyboard layout.  This is actually kinda common and happens to many users, in many contexts (see also https://eu.battle.net/forums/en/sc2/topic/1549671301 and https://discussions.apple.com/thread/5600884?start=0&tstart=0 and https://groups.google.com/forum/#!topic/adobe.illustrator.windows/EyC1gjF7mLo ).  Keyboards such as German and Polish swap the locations of Z and Y.

Hope that helps,
David