Lightroom 6.2: Random bugs topped by Full Initialisation

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
Generally I have admired your products and quality. However I have been very unhappy with V6 of Lightroom and your related "Application Manager". I have had serious problems with both requiring your support people to remote in to fix it when it decided I didn't have a licence. This has been exacerbated in V6.2 which has been one of the most broken pieces of software I've ever had to use. Note I say 'had to'; I am trying to run a business and it isn't just a nuisance when it misbehaves. I presume because my wife started editing in V6 for the 1st time last night; this morning it really failed! It completely initialised itself like I had never used it before. Everything was gone and replaced with a completely empty default set up! Did not enjoy being forced to watch your advert. I have now spent hours trying to repoint it at existing catalogues, pre-sets etc. and restore all my preferences. The notes for 6.3 are interesting indeed but somehow I'm still nervous about getting it given my recent experiences. I LOL'd about it reverting to the 'classic' import. Much calmer now than earlier.

I've been doing this since version 1, for various reasons it seems we have to re-apply our preferences every now and then, by hand. Gets more frustrating over time as you make them more obscure, like backup location. So here's an idea to share. As a developer, for decades I wrote code to use plain English parameter files in simple locations. How about Lightroom puts backups of all preferences and pre-sets etc. and the catalogue together. Then make it as simple to restore those, as it is the catalogue?
Photo of Jeremy Wood

Jeremy Wood

  • 15 Posts
  • 1 Reply Like

Posted 3 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
Go download and install the LR 6.3 update. They fixed a lot of bugs in 6.3, in addition to restoring the old import UI.