Lightroom Classic: Everything slow after update

  • 2
  • Problem
  • Updated 8 months ago
  • (Edited)
From last upgrade everything work so slowly. I cant normal use Adobe products!
Photo of Roland Stepien

Roland Stepien

  • 4 Posts
  • 0 Reply Likes

Posted 8 months ago

  • 2
Photo of Sunil Bhaskaran

Sunil Bhaskaran, Official Rep

  • 352 Posts
  • 121 Reply Likes
Roland,
Could you please provide us with the Sys Info? (Help > System Info)

Thanks,
Sunil
Photo of Roland Stepien

Roland Stepien

  • 4 Posts
  • 0 Reply Likes
Win10 x64
I5-2450 CPU
2.50 GHz 2.50 GHz
8GB ram
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4391 Posts
  • 846 Reply Likes
Roland, 

Often this is the result of a problem with the installation.  You don't mention whether you are using the Classic CC or the CC version of Lightroom but the procedure is the same. 

Please follow these steps: 

1. Uninstall Lightroom Classic CC from your Windows machine using the Creative Cloud App.
2. Restart your computer. 
3. Open the Creative Cloud App and install via the App and it will use a fresh download. 

After the reinstallation, do you still see the same same slow behavior? 
Photo of Roland Stepien

Roland Stepien

  • 4 Posts
  • 0 Reply Likes
still slow
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4391 Posts
  • 846 Reply Likes
Roland,

Can you describe specifically what is slow? Is it importing? Scrolling a grid of thumbnails? Applying a spot brush? Something else.  A specific example of behavior that is slow and an idea of how many seconds/minutes it takes will go a long way toward helping us diagnose your slowness. It will also allow us to test the operation and provide you with some comparison for what is expected. 

Thanks for your help.
(Edited)
Photo of Roland Stepien

Roland Stepien

  • 4 Posts
  • 0 Reply Likes
everything: import, export, scrolling, brush, every slider, spot remowal. Thats works few times slower like before upgrade.