Photoshop Elements: Updating Camera Raw Converter - version 6.3

  • 1
  • Question
  • Updated 6 years ago
  • (Edited)
For the past year I have been able to open RAW files in my Elements 9 Editor. To day suddenly I find a message "Couldn't complete your request because of a program error".

Checking under Menu Help > Plug ins > ACR, if find I have version 6.1.0.250 installed - even though I had downloaded/installed version 6.3 a year ago (which is what my Canon 60D needs).

So I try, via the Adobe Downloads to reinstall 6.3. All goes well to the point where two folders show on my Desktop (A yellow one: Camera Raw 6 3.zip undate.zip. and a blue Pse one: Camera Raw 6 3 update. part). If I try to unzip/install the yellow one, the Auto-installer say, "No files to install". If I try and open the blue Pse one Elements say, "wrong type of file".

How do I install ACR version 6.3? Please help.

Nielen
Photo of Nielen Schaefer

Nielen Schaefer

  • 29 Posts
  • 2 Reply Likes

Posted 6 years ago

  • 1
Photo of PECourtejoie

PECourtejoie, Champion

  • 792 Posts
  • 283 Reply Likes
Hello! you should be updating to the latest compatible version with PsEl9, that is Camera Raw 6.5. You are maybe downloading files for the other operating system (Mac/PC)
Without knowing your plaftorm, check the links for Elements 9 for your platform in this FAQ thread: http://forums.adobe.com/thread/311515...
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14049 Posts
  • 1735 Reply Likes
Have you tried selecting Help>Updates... from Elements?
Photo of Nielen Schaefer

Nielen Schaefer

  • 29 Posts
  • 2 Reply Likes
Hi guys, Thanks form coming back to me so smartly.

Last night I approached the issue in a round-about way, and have been successful. Downloaded the update on a friends computer (where it immediately followed a different track: took 10 minutes to download, came up with different looking folders, both yellow zip, different file names, etc . . .

Copied this download to my computer where it was unzipped and then installed without any trouble. So all is now in order.
(Accept that you say I should update to 6.5 - will have to repeat the whole successful process)!

The initial fault therefore seems to lie somewhere within my own computer: maybe a security setting that is preventing me from entering Internet download sites. I cannot find anything obvious in my Avast Virus Checker, or in FireFox.

Good day Jeffrey.
I am the same person who originally contacted you regarding "Marching Ants that Freeze up." You asked me at the time to send you System Information and screen-shots of some of the anomalies I was facing - which I did ten days ago, posted to the email address you gave me. Sent on 27 January, under my name. Hope you received these, and that they are assisting to solve those rather annoying problems)

Nielen Schaefer
South Africa.