Updated to 7.4 - ugh - from library to develop is a no go

  • 1
  • Problem
  • Updated 4 months ago
Updated LR CC from 7.3 to 7.4.  When going from library to develop mode, view screen for image is black.  I have reviewed associated posts and no current fixes listed correct the issue.  I await your reply.  System is new Dell - i7-6700 cpu - 16 GB - 64 bit
Photo of Sam Phillips

Sam Phillips

  • 1 Post
  • 0 Reply Likes
  • frustrated that you do the same thing as microsoft - put junk out there

Posted 4 months ago

  • 1
Photo of Ruurd van Dijk

Ruurd van Dijk

  • 17 Posts
  • 3 Reply Likes
Did you try switching off your GPU in preferences?
Photo of Nick Prime

Nick Prime

  • 4 Posts
  • 0 Reply Likes
yes, as mentioned, I searched through all of the suggested remedies - none worked
Photo of Nick Prime

Nick Prime

  • 4 Posts
  • 0 Reply Likes
I'm the Son-In-Law BTW.
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2657 Posts
  • 341 Reply Likes
Since we don't know what you've tried we can only just keep telling you things to try:
  • Toggled Use-GPU preference - nothing different according to you.
  • Have you let it sit for a few minutes to make sure it's just not busy?
  • Is the histogram area also messed up?
  • Have you rebooted?
  • Have you powered off and rebooted?
  • Have you shut down LR with Develop as the current module, rebooted, started LR, in case it's related to the switching instead of the module you're in?  Switch back to Library after you test this.
  • Have you tried a new empty catalog, imported one JPG photo, and switched between Library and Develop?  Make note of the current catalog so you can go back to it.
  • Have you purged the Video preview cache?  Is the current photo a video?
  • Have you deleted the catalogname-Previews.lrdata preview cache folder with LR shut down?  Is the current photo not a video?
  • Have you tried importing a JPG and making it the current photo before switching?
  • Have you created and are using a new display profile using the Windows Calibration in the Advanced display properties?  It's the thing with the gamma dots and the guy with a white shirt in a black room.
  • Have you run chkdsk/scandisk?
  • Have you run a memory check, at least a quick one?
  • Are you current in Windows Updates?
  • Are you current on Windows version 1803?
  • Have you updated your video drivers from the video-card manufacturer's site?
  • Have you switched off Antivirus temporarily?
  • Have you unplugged unnecessary USB devices?
These suggestions are all about either there being a hardware problem, a driver problem, a disk problem or a file problem or an OS or maintenance-software problem.
(Edited)
Photo of Nick Prime

Nick Prime

  • 4 Posts
  • 0 Reply Likes
Son-In-Law here, I tried pretty much every thing you listed all with no positive results, hence the current uninstall of 7.4 and back to 7.2  At 92, he's happy with the way I have it running now so for now, we'll just rock on the way it is.  Many thanks though for your efforts.
Photo of ragrawal

ragrawal, Employee

  • 23 Posts
  • 4 Reply Likes
Hi Sam,

Is this happening with all the images and only on this particular system?

Rahul Agrawal
Photo of Nick Prime

Nick Prime

  • 4 Posts
  • 0 Reply Likes
Son-In-Law here, yes.