Lightroom Classic: Will not open after I updated my Mac

  • 1
  • Problem
  • Updated 4 weeks ago
  • (Edited)
I am running the latest LR Classic CC and update my Mac to the latest version of Mojave. LR now will not open. I see the black dot underneath the icon for about 2 seconds and nothing. I have reinstalled LR, turned the machine off and on, signed out of CC, removed Library files....all of the stuff I have seen people do in the past, but to no avail.
Photo of Jeff Wingo

Jeff Wingo

  • 1 Post
  • 0 Reply Likes
  • upset.

Posted 4 weeks ago

  • 1
Photo of Carlos Cardona

Carlos Cardona

  • 323 Posts
  • 66 Reply Likes
Please give your Mac the "once over"! Run the free Onyx (https://www.titanium-software.fr/en/o...), reboot. (In Onyx just select and run everything in the Automation tab). That SHOULD do it, but if not run Disk Warrior if you can ($120), (https://www.alsoft.com), reboot. If you can’t do Disk Warrior, at least run First Aid from Disk Utility. Also just doing a "Safe Boot" can clear out caches (restart, hold down shift until you see "Safe Boot" on the screen, then reboot normally.

The main issue, fixed by Onyx, is a corrupt application state.
Photo of rfmiller

rfmiller

  • 12 Posts
  • 0 Reply Likes
If you are on the latest version, 8.0, many of us have found it to be very buggy.  Especially those of us using the book module where it will not save work done and randomly deletes items.  Hopefully there will be a fix soon and no need to go back to 7.5 to complete book projects.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4435 Posts
  • 870 Reply Likes
A clean reinstall will likely help the issue:

Close Lightroom
Restart the computer
Use the Adobe Creative Cloud App to uninstall Lightroom Classic CC
Restart the computer
Install Lightroom Classic CC via the Creative Cloud App without launching any other programs.
Restart the computer
Launch Lightroom
Wait 5 minutes

Let us know if it will launch now.