Lightroom: 4.2 update fails

  • 4
  • Problem
  • Updated 6 years ago
  • Solved
  • (Edited)
Lightroom 4.2 update extracts almost all files. Unfortunately Setup64.exe is not extracted and I need the 64 bit setup, because I have windows 7 64 bit and Lightroom 4 is already updated to 4.1 also 64 bit. I have enough room on my harddisk ( > 1 Tb).
Photo of Erik Houet

Erik Houet

  • 8 Posts
  • 1 Reply Like

Posted 6 years ago

  • 4
Photo of James Hess

James Hess

  • 168 Posts
  • 23 Reply Likes
I just ran the installer. It created a folder with a sub folder that contained the two executables, 32 bit and 64 bit. Are you sure the installer you have didn't do that?
Photo of Erik Houet

Erik Houet

  • 8 Posts
  • 1 Reply Like
The installer did do that, but the file size of the setup64.exe is 0 byte.
Photo of James Hess

James Hess

  • 168 Posts
  • 23 Reply Likes
That is really strange! Have you tried downloading it again?
Photo of Erik Houet

Erik Houet

  • 8 Posts
  • 1 Reply Like
about five times with the same results
Photo of James Hess

James Hess

  • 168 Posts
  • 23 Reply Likes
Well, if I had your e-mail address I could send you a Sky Drive link, and you could download my copy.
Photo of Erik Houet

Erik Houet

  • 8 Posts
  • 1 Reply Like
ehouet at gmail dot com
Photo of James Hess

James Hess

  • 168 Posts
  • 23 Reply Likes
I thought that would work, but the file is too large. Also tried Dropbox, same problem.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13977 Posts
  • 1665 Reply Likes
What browser are you using? Which URL are you downloading from?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13977 Posts
  • 1665 Reply Likes
Which extraction tool are you using?
Photo of Erik Houet

Erik Houet

  • 8 Posts
  • 1 Reply Like
Browser: Firefox
URL: http://www.adobe.com/support/download... (just from New Downloads -> Lightroom)

No extraction tool. When I start the executable it extracts the files to a specific location. All files (or almost all files) are extracted to the folder. But Setup64.exe appears to be 0 kb in size.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 3818 Posts
  • 1265 Reply Likes
Can you try an alternative browser please Erik?
Photo of James Hess

James Hess

  • 168 Posts
  • 23 Reply Likes
I downloaded using Firefox, and everything went well. I was actually able to send the 64-bit installer to Erik, but when he ran it he got the message that there was a missing MSI file. There wasn't one in that folder. So I don't know how to help him anymore.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 3818 Posts
  • 1265 Reply Likes
Try the instructions on this thread: http://forums.adobe.com/message/4762592
Photo of Erik Houet

Erik Houet

  • 8 Posts
  • 1 Reply Like
The problem is getting stranger. Because James sent me the setup64.exe, I tried to run the setup, but an error occurred at the end. When rolling back, I got another error so I could not run Lightroom any more. When I tried to reinstall update 4.1 I got the same error message as the update of 4.2. I could use the 4.1 update before, but now I get the same error message as with 4.2 and not all files are extracted.
How can I fix this problem? All latest updates are installed from Microsoft.
But could it be that the installer Adobe uses, fails with some of these updates?
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 3818 Posts
  • 1265 Reply Likes
Did you see the 'solution' at the top of the thread I linked to? "Solution found -- Windows installer issues / registry issues -- used the Microsoft Fix it tool (http://support.microsoft.com/kb/24386...) to correct. 4.2 install ran fine."
Photo of Erik Houet

Erik Houet

  • 8 Posts
  • 1 Reply Like
That didn't work. My error message is different any way.
It is something like this (sorry I get the error message in dutch):
"There was a problem during extracting some files. Please check the available space on the computer and if you have enough privileges to write in the destination folder."

Most of the times it gets stuck on Setup64.exe, in other cases a bit earlier.
When I tried to install the update 4.1 again, it had the same problem.
Update 4.1 also stops in most cases on setup64.exe.
I tried to install both updates without my anti-virus program running. But this had the same effect.
But this update used to work (I already installed this file with succes).
Photo of Erik Houet

Erik Houet

  • 8 Posts
  • 1 Reply Like
You're not going to believe this. But the downloaded file extracted all files, even the Setup64.exe. And the installation went well.

I found some information about the Windows Installer and I tried the following:
* open Cmd as Administrator
* type "msexec /unregister"
* type "msexec /regserver"
and try to install the program again. And that seems to work. Finally.

Thanx for the help you all!!!
Photo of Andrew Chadwick

Andrew Chadwick

  • 1 Post
  • 0 Reply Likes
I have the same problem as Erik Houet and tried his fix, typing msiexec not msexec each time, which is recognised, but still get the message 'a problem occurred while extracting files etc, with plenty of disk space, and ansetup64.exe length of 0. IS there an official fix for this?