Lightroom: How do I prevent Lightroom from launching when I plug in my card reader?

  • 2
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
Lightroom 3 starts up when I plug in a card into my card reader. How can I stop this?
Photo of Steven Tanihara

Steven Tanihara

  • 1 Post
  • 0 Reply Likes

Posted 8 years ago

  • 2
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15586 Posts
  • 2344 Reply Likes
Official Response
From Lightroom's preferences, uncheck "Show import dialog when a memory card is detected" to avoid having Lightroom launch when a memory card or hard drive is inserted/mounted:

Photo of Juliet Evans

Juliet Evans

  • 2 Posts
  • 0 Reply Likes
Lightroom 3 with Windows 7 (and ealier versions) everytime I add a memory stick lightroom opens. This would be OK if it were just pictures but a mempry stick full of word documents? its crazy and has to be fixed, please.

This reply was created from a merged topic originally titled
Lightroom: How do I prevent Lightroom from automatically opening when I mount a camera card?.
Photo of PhotoGene47

PhotoGene47

  • 13 Posts
  • 3 Reply Likes
For those, like me, that have a problem with Lightroom activating (Windows) whenever an external device is attached, the solution above does not fix it because AutoPlay is now in charge. Using the search function (if you do not know where this settings feature is located) type in AutoPlay Settings.  In Windows 10, there will be two entries. One is for a removable drive and the other is for a memory card. Change these to "Take No Action" and it should solve the problem. I inadvertently checked the memory card box in Lightroom. That is when the problem started. However, going back into Lightroom and unchecking the box did not correct the problem. It seems that Lightroom made a change in Windows.  When the box is unchecked, it does not restore the AutoPlay setting in Windows to its previous setting. That is what happened to me at any rate. I changed the setting and now all is fine when I attach an external drive or memory card.