Unusual interface issues with Lightroom on iMac 27 ret

  • 1
  • Problem
  • Updated 3 years ago
I am a former Aperture user transitioning to Lightroom using version 6.1.1 on a 2014 iMac 27 Retina

When working in 5K screen resolution using Smart Previews of NEF Camera Raw files, I am seeing unusual interface issues.

1- In the LIBRARY or DEVELOP module in LOUPE view when previews are set to FIT they appear at two sizes seemingly at random.
Sometimes the preview will load large (2966x1986) then shrink smaller (2566x1714).
Sometimes some of the previews will stay small and other times some will stay large.
Sometimes formerly large previews will show small when reselecting them.

2- Another random occurrence is the previews in grid view become unresponsive to mouse clicks.
When this happens, of the 1200 previews in grid view, the first 50 may work properly but the rest do not respond to a mouse click. A restart of the app is required to fix the issue.

I read about problems with Adobe apps from a year ago when the iMac 27 Retina first became available but I thought by now all of those issues would have been solved.

Is Adobe still working through issues with the 5K iMac ?
Photo of Tom Hughes

Tom Hughes

  • 1 Post
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Lynn Oakleaf

Lynn Oakleaf

  • 64 Posts
  • 3 Reply Likes
Adobe is having issues with the 6.1.x and 6.2.x versions period, and then if you're on the latest version of OS from Apple you can quadruple the problems
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4104 Posts
  • 1468 Reply Likes
When you say you're using smart previews, do you mean the originals are offline?

Large previews that are out of date (you've made Develop changes since they were rendered) and are then updated to show your Develop changes would shrink in that scenario, as the smart previews are only 2560px along the longest edge.