Photoshop: Untenable troubleshooting

  • 1
  • Problem
  • Updated 3 months ago
  • (Edited)
Honestly, I dread having to use Adobe, I know it's going to be an exercise in wasted time and productivity trying to troubleshoot the problems at the expense of my actual work. I've used PS for 20 years. I used to love it. Now I approach it skeptically wondering what problems I'll encounter today. Today: Open photoshop to add a simple headline onto an image and send the jpeg to a client. This should take under 5 minutes. Here's what happened 1) Opening PS takes up to 7 minutes. 2) Opened the image, added text, tried to change the font. Hanging for many minutes, closed PS. Tried to reopen PS. Would not open. Contact customer support. An hour goes by. The problem is fixed for now, but the client is not understanding about why it took so long to do something so basic. This makes me look unprofessional, when my tools don't function. This comes off of a 4-hour Adobe customer support session from yesterday. They told me "Everything is fixed, you won't have any more problems." as they did today at the end of my hour+ session. The functionality of the cloud is not where it should be. This is when it all went downhill. Innovation is not helpful at the expense of functionality. iOS, Catalina. CC.
Photo of kayaak

kayaak

  • 1 Post
  • 0 Reply Likes
  • like I need to look elsewhere for functional software.

Posted 3 months ago

  • 1
Photo of David

David, Official Rep

  • 3602 Posts
  • 615 Reply Likes
Hi,

Could it be that you have one or more fonts that could be corrupt OR that your font cache could have become corrupt?  Try checking out the steps listed here, particularly steps #5, #6, and #7: https://helpx.adobe.com/photoshop/kb/troubleshoot-fonts-photoshop.html  Also, if you continue to have problems, please ping me here and I'd be happy to act as Tech Support via a live screenshare.  We'll get this sorted for you.
Thanks,David
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17063 Posts
  • 2904 Reply Likes
Looks like an activation issue with CCDA needed to be addressed and prefs restore fixed it from the agent notes.