Elements 12: Unnecessary failure during photo import in Organizer

  • 4
  • Problem
  • Updated 3 years ago
  • (Edited)
I scanned multiple old photos using a Canon multi-purpose machine into JPGs. Every image program I open them in works just fine, but when the Adobe Elements 12 Organizer gets to them during an import, the import fails completely and no further images are imported. It took me hours to figure out which image(s) were causing the failure. I am very upset at the error handling qualities of the organizer. If a photo fails to import, it should simply be skipped, and a message regarding the failure sent to the user. If you need a sample of the image causing the problem, I'd be happy to send it to you so you may resolve this flaw. Please feel free to contact me at the email address on file.
Photo of James Hunt

James Hunt

  • 4 Posts
  • 0 Reply Likes
  • very concerned about the quality of this product

Posted 5 years ago

  • 4
Photo of James Hunt

James Hunt

  • 4 Posts
  • 0 Reply Likes
I just removed all of the photos that were causing the "Import failed." problem in the first folder and now it has hit a snag in another folder with totally unrelated photos. They were taken with a different camera and also do not appear to be corrupted. All of the photos that are causing a failure have been jpg's so shouldn't be a problem. I cannot figure out what the problem is here.... How many people are using Organizer out there? Is anyone with large quantities of photos having good luck with it? I have approximately 36,000 so this is getting real frustrating.
Photo of Michel BRETECHER

Michel BRETECHER, Champion

  • 1123 Posts
  • 235 Reply Likes
What's not clear in your description is which method you are using to import your pictures (I understand they are scanned pictures):
- Menu 'Get photos from files and folders' - that's if you are using the software delivered with your scanner to write the files to your drive
- or if you are using the 'import' button on the top left of your organizer display to open the scanner driver (I would think so).

The troubleshooting steps will be different in each case.
Other useful information would be the format of the files (jpegs, tiffs) and their size in pixels.

Would you be able to upload your scans with the external Canon software and save them as jpeg or tiff on your computer ? In that case would you be able to open the files from the editor ? Would the organizer be able to 'get files from files and folders ?

By the way, the size of the catalog has nothing to do with your problem. 36.000 items is not even a big size.
Photo of andaleeb

andaleeb, Employee

  • 157 Posts
  • 21 Reply Likes
Hi James,

We would like to look into what is causing the issue in your case. Can you please share a few test files with us?
As I understand, you have already scanned and saved these images somewhere on your hard drive and is now importing via Get Photos and Video From Files and Folders?

Thanks
Andaleeb
Photo of James Hunt

James Hunt

  • 4 Posts
  • 0 Reply Likes
The 'Original' and 'Digitised' dates in a freeware program called EXIF Data Viewer reveal dates of 12/30/1899 12:00:00 PM for the problem photos. My guess is that's what appears for a null value. Whether the images have no EXIF value for the date, or they actually have a value but it is outside of a range that Elements organizer can handle is not known to me, but it will choke on them every time. In any case, changing these dates to a random date in the 80's fixed the problem. Finding every picture in my library that has this same data structure is a daunting task as I'll have to wait for Adobe to fail each time, hunt down the image and then manually change the date. Let's hope Adobe can work up a patch for this one and save lots of people (assuming they haven't all given up on this software already) some time and frustration.
(Edited)
Photo of James Hunt

James Hunt

  • 4 Posts
  • 0 Reply Likes
Ok, I found a couple of the offending photos and I'll upload them here. I also took a screen shot of the EXIF data viewer freeware I used to figure out what the problem was. Look at the dates for 'Original' and 'Digitised' in the photos. Changing these values fixes the import failure. Also, you are correct in assuming that I was importing photos from files or folders.
(Edited)
Photo of andaleeb

andaleeb, Employee

  • 157 Posts
  • 21 Reply Likes
Hi James,

Can you please email me this image at my ID (afatima@adobe.com). If I download it from here, the date time changes.
If convenient you may also share it through Dropbox or any other means which won't modify date/time of the original file.

Thanks
Andaleeb
Photo of K.O. (Win-Premier)

K.O. (Win-Premier)

  • 1 Post
  • 0 Reply Likes
I saw this solution on another board somewhere and it worked for me.

I was starting new with PSE 13 (coming from Picasa) and hundreds of photos wouldn't load into the organizer. The error would be "The file is damaged or is in a format that cannot be included in Elements Organizer" yet these files are viewable in Picasa and via Windows.

Here is the solution. Open the PSE editor and load the problem photos. Then go to File > Organize Open Files. This will save all the files you loaded into the organizer and you're done.

Don't ask me or get me started on why the Organizer can't just load them initially if you can load them from the editor but hope this helps. It worked for me.
Photo of John Keller

John Keller

  • 2 Posts
  • 0 Reply Likes
Thanks, Kevin. Your trick worked for me to get a particular photo into Organizer. But when I tried Import Files again to bring in the rest of my files, amazingly Organizer hung up on the same photo file which was ALREADY in Organizer. Nothing unusual about the photo (from a Nikon point/shoot; not renamed or edited at this point). Very frustrating.
Photo of andaleeb

andaleeb, Employee

  • 157 Posts
  • 21 Reply Likes
Hi John,

Can you please let me know the version you are working on? Is the issue consistent with this particular files?

Thanks
Andaleeb
Photo of Richard W Rose

Richard W Rose

  • 6 Posts
  • 0 Reply Likes
How can I stop Organizer from importing files that are not where Organizer imported them to? I mainly use Organizer to import the image off my camera, this time I forgot to change the location to save them in. After the downloading was complete the folder was moved to where it was to have been saved. Now Organizer wants to import these non-existent pictures into itself and hangs. It hangs itself now every time Organizer is opened trying to import the picture that do not exist where it is looking for them. Most application when they cannot find what is requested display an error message and move on. I say most applications because Adobe software does not. This renders Organizer useless for all future usage.
Photo of andaleeb

andaleeb, Employee

  • 157 Posts
  • 21 Reply Likes
Hi Richard,
I shall get back to you tomorrow, on the email you sent. 
Thanks for writing in.

Regards
Andaleeb
Photo of Richard W Rose

Richard W Rose

  • 6 Posts
  • 0 Reply Likes
Ver 12
Photo of Michel BRETECHER

Michel BRETECHER, Champion

  • 1123 Posts
  • 235 Reply Likes
" the folder was moved to where it was to have been saved".
Do you mean you moved the folders from the Explorer/Finder instead of moving them from the Organizer? (Golden rule: never move, delete or rename files outside of the organizer).
If so, easiest solution: move them back from the Explorer/Finder to the original location; then move them from the Organizer where you want.
Otherwise, we need more details about what you did.

Two tips:
- In the Edit/preferences menu, 'File' section, uncheck 'Search and reconnect automatically disconnected files'. Better choose yourself when you want such reconnection process.
- In the file menu, have a look at the 'watched folders' option. Don't include too many folders, just those where you expect your files to be downloaded.
Photo of Richard W Rose

Richard W Rose

  • 6 Posts
  • 0 Reply Likes
Thank you, it finally gave up trying to import those files. Which allowed me to implement your suggestions. That should cure it. The biggest problem was when it opened it always open with the import option. Selecting "No" did not make a difference, it tried find and import any way. That was the biggest problem the selection box was ignored.
Photo of Max Scott

Max Scott

  • 2 Posts
  • 0 Reply Likes
I have a similar problem involving Photoshop Elements Version 12. Organizer has stopped importing files, regardless of the file type. There were some files with duplicate dates and I have no ideal how that happened. I made sure the date settings on my cameras were accurate but the file numbers appear to be ones previously used- that would be the reason Organizer will not import files. Anyone else experiencing anything ;like this?

Now for the best part- I went into the folders and renamed the offending files with numbers / names not already in use BUT Organizer says the files already exist. HELP!!!!
Photo of andaleeb

andaleeb, Employee

  • 157 Posts
  • 21 Reply Likes
Hi Max,

I have written a mail to you regarding more information. Please see.

Thanks
Andaleeb
Photo of Gaylene Erwin

Gaylene Erwin

  • 2 Posts
  • 0 Reply Likes
I am having the same trouble as Max Scott. Please help me!! I am getting so frustrated!!!
Photo of Max Scott

Max Scott

  • 2 Posts
  • 0 Reply Likes
I found a suggestion on the Forum pertaining to "Failure to Import" that seems to work for me- Change the Catalog.

Open Adobe Photoshop Elements (PSE) - Select "File"
Select "Manage Catalogs . . ."
Under the drop down menu titled "Catalog Manager" select "New."
Create a new catalog and use it for your default. Be sure to change your import window to reflect the new catalog name and path. This change will not fix the problem and it does create a new problem with name tags, picture titles and on and on. . . .But, it will allow you to continue to use PSE. I'm sorry I have taken so long to get back to the forum but I will be a little more attentive in the future.
Photo of Gaylene Erwin

Gaylene Erwin

  • 2 Posts
  • 0 Reply Likes
Thank you so much for the information.. I'm going to try it. I sure hope it works. Many thanks !!