Unacceptable performance

  • 2
  • Problem
  • Updated 2 weeks ago
I'm using an iMac that less than a couple of years ago was the top-of-the-line model (4K display, 4GHz processor, 32GB RAM). After the last Photoshop update, I can no longer use some tools effectively. This is especially troublesome when using brushes. After a couple of seconds of brushing, the brush disappears even though its effects still get applied, then a couple of seconds later everything freezes with the spinning rainbow cursor.

The only applications running in parallel are Photoshop and Lightroom (Classic).

Adobe, please reconsider your priorities. I'm sure most of your users would consider such things as improvements to content-aware algorithm as much less important than actually getting their work done.
Lightroom has reached the too-sluggish-to-work-effectively level a couple of versions ago.
Photo of Guy Tal

Guy Tal

  • 7 Posts
  • 0 Reply Likes

Posted 2 weeks ago

  • 2
Photo of Carlos Cardona

Carlos Cardona

  • 323 Posts
  • 66 Reply Likes
Guy I have a similar iMac, (16GB RAM) and the same problem (which happens when software get more features): you need at least 64GB, to run LR and PS, and ANY other apps, like Mail or Calendar. Try running Memory Clean and set it to view percentage, and clean it when you get under 10%.

I do this 5-10 times a day, with only the 2 apps open, just to get through my work. Waiting for 2019 for new iMac with Gen 8 processors, 64 GB RAM, and “significantly improved display specifications”.

Not Adobe’s fault, just what happens over time to software.
(Edited)
Photo of Guy Tal

Guy Tal

  • 7 Posts
  • 0 Reply Likes
Thank you, Carlos. I agree in general, but I don't think a top-of-the-line computer less than 2 years old should be obsolete. I sincerely hope that using Adobe software doesn't come with the additional cost of replacing a computer every year or two.
Photo of karelu

karelu

  • 12 Posts
  • 2 Reply Likes
I concur.. Top 27" iMac (2017) with 40Gb of RAM.. and the interface is just plain slow. I simply cannot believe that this is the best Adobe can do. Switching between Library and Develop is taking a second... this should be instant! 40Gb of RAM and the photos and catalogue on internal Flash...
I would not mind at all that an Lightroom CC Classic interim release does not contain any additional features if they just would do something about the performance of the programme.

Karel.
Photo of dmeephd

dmeephd

  • 234 Posts
  • 51 Reply Likes
Agree completely.  I would kill for a release which focused solely on performance improvements.  I'm running a MacPro with a six-core 3.5GHz CPU, two 8GB GPU, a 4TB SSD, and 128GB RAM.  LR 7.5 was far slower than LR6, although Mojave improved performance somewhat, and LR8 is just a pig.

LR fails to use the multiple cores effectively, and never touches the second GPU ever.

A release which improved performance to at least match AutoCAD would be a blessing.  I couldn't care less about GPS mapping, facial recognition (which doesn't work worth a damn), and other 'content-aware' BS; there's real money-making work to be done!
Photo of Ryan Smith

Ryan Smith

  • 26 Posts
  • 7 Reply Likes
That's strange I had an iMac 2015 top of the line 27' 5k 24gb ram and everything worked great.  I recently upgraded to a 2018 Mac Mini 6 core i7 and it was terrible, I realized you can't use adobe apps at 4k without a real gpu.  After I added on a egpu everything works good again.  I have a huge library about 700k images so I'm not sure where you issue is coming from.   
Photo of dmeephd

dmeephd

  • 237 Posts
  • 51 Reply Likes
My catalog currently has 3.7M images.  (Just a wee bit larger.)  Unfortunately, the 2013 MacPro does not have TB3, so an eGPU is not in the cards, and I've read there's no new version of the MacPro in 2019.

However, I'm driving three (3) LG 34" HD displays...not at 4k; they're 3440 x 1440 (WQHD).  Why Adobe cannot write a program which uses multiple GPUs is beyond understanding.  Autodesk has no problems doing this with its AutoCAD family of programs.
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 711 Posts
  • 296 Reply Likes
Hi Guy,

Are you running Mojave? If you are would you please try this workaround and let me know if it helps?

After applying the 20.0.1 update, you will need to do the following for macOS 10.14.1:

Run the following command from the Terminal (to go directly Terminal, press command + space bar, start typing "terminal" and hit return):
defaults write -g PhotoshopForceLegacyPaintMode -bool Yes
Then you have to enable Photoshop in System Preferences > Security > Accessibility

Thanks,
Hannah
Photo of Guy Tal

Guy Tal

  • 7 Posts
  • 0 Reply Likes

Thank you, Hannah! Yes, I am running Mojave.

Before I change any configuration on my computer, can you please explain in detail what this setting does, what the difference is between legacy paint mode and the current implementation, and whether this setting will be supported in future versions (no point if it ends up being de-supported in a future version)?
Photo of karelu

karelu

  • 12 Posts
  • 2 Reply Likes
Hi Hannah,

We're talking about Lightroom Classic here... Does the 'photoshop' setting have impact in Lightroom too? And what exactly does this do?

Karel.
Photo of Guy Tal

Guy Tal

  • 7 Posts
  • 0 Reply Likes
I'm sorry, Karelu, but my original post is about Photoshop, and that's the application I want an answer for. Perhaps it's worth starting a separate case for Lightroom?
Photo of karelu

karelu

  • 12 Posts
  • 2 Reply Likes
Oh.. sorry... ibecause t mentioned also "Products : Lightroom Classic CC" on top of this page.
Karel.