Elements 13: Unable to open my catalog because of an internal program problem

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
when i open the organizer it tries to open my catalog but I get an internal programming error has occurred
Photo of Antonio Quate

Antonio Quate

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 5 years ago

  • 1
Photo of Sandeep Singh

Sandeep Singh, Official Rep

  • 107 Posts
  • 18 Reply Likes
Official Response
Hi Antonio,

This issue might be coming because of a corrupt catalog.
Please try to create a new catalog.
Go to following location
C:\ProgramData\Adobe\Elements Organizer\Catalogs
Rename the folder My Catalog to My Catalog.old

Try to launch Elements Organizer now

Please let me know if this works out.

Photo of Antonio Quate

Antonio Quate

  • 2 Posts
  • 0 Reply Likes
Yes it worked
Photo of Cheryl Cristello

Cheryl Cristello

  • 3 Posts
  • 0 Reply Likes
I too get a message saying that my catalog is corrupt- I've searched for the location cited by Sandeep above as well as all variations which I can think of but so far I have not been able to locate the catalog. I'm using an iMac running OS X Yosemite 10.10.4

Thanks for any help which you can provide as I'm really frustrated!