Elements: Unable to change printers in PSE 13 Editor

  • 2
  • Problem
  • Updated 5 years ago
  • (Edited)
IN PSE13 Editor I want to route my print to a different printer (a Canon instead of my usual Epson). This hasn't caused a problem in earlier versions of PSE, and it works when printing from the PSE13 Organiser.

In the "Select printer" box I choose my Canon and the relevant printer settings.

But when I click Print, it always goes to the Epson.

Rebooting and changing the Win8 default printer makes no difference. Both printers are locally attached, have no queued jobs, and work fine from other applications.
Photo of Rod Bird

Rod Bird

  • 9 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 2
Photo of Rod Bird

Rod Bird

  • 9 Posts
  • 0 Reply Likes
Oops - I meant 64 bit Windows 7.
Photo of Neeraj

Neeraj, Employee

  • 122 Posts
  • 13 Reply Likes
Hi , 

Do one thing After changing select Printer pop-up in print dialog ,also click Change settings button and look everything fine or not (If Printer name is not appearing correct change it) and then print it. 
If it does not solve the problem
Please go control panel > Device and printers and try to change default printer 
Then check PSE editor print behavior.
(Edited)
Photo of Rod Bird

Rod Bird

  • 9 Posts
  • 0 Reply Likes
Thanks. After choosing a printer in the dialog, the settings apply to the printer I've chosen. I made a minor change (to prt quality) and pressed Print. The output still goes to the original printer instead of the selected one.

In Control Panel I've changed the default printer. It's made no difference.
Photo of Richard Debertin

Richard Debertin

  • 9 Posts
  • 0 Reply Likes
Have same problem is there an answer
Photo of Rod Bird

Rod Bird

  • 9 Posts
  • 0 Reply Likes
For info: I installed PSE13 and both printers on another W7 machine. The problem does not occur on that one.
Photo of Neeraj

Neeraj, Employee

  • 122 Posts
  • 13 Reply Likes
HI , 

Just a quick question -
From other applications did it print fine ?
Photo of Rod Bird

Rod Bird

  • 9 Posts
  • 0 Reply Likes
Yes Neeraj, all other applications (including PSE11 Editor and PSE12 Editor) print perfectly.
Photo of Neeraj

Neeraj, Employee

  • 122 Posts
  • 13 Reply Likes
Hi ,

Please rename your printer with different name like 'Eposn my own printer' or any other name as per you and and try printing with the same.
Photo of Richard Debertin

Richard Debertin

  • 9 Posts
  • 0 Reply Likes
Did that an no change in behavior
Photo of Rod Bird

Rod Bird

  • 9 Posts
  • 0 Reply Likes
I have renamed both printers as you suggest Neeraj. I rebooted and tried printing.

As before, I can select either printer, and when I've done so the Printer Options are consistent with the one I've chosen. But in PSE13 the print always goes to my Epson R2880 even when I chose the Canon laser printer.

I have just checked again in PSE12 and the print goes to the printer I choose.
Photo of Rod Bird

Rod Bird

  • 9 Posts
  • 0 Reply Likes
Shall I reinstall PSE13?
Photo of Richard Debertin

Richard Debertin

  • 9 Posts
  • 0 Reply Likes
Same problem different printers. was working fine now will not change to a different printer. Yes I have newest drivers, Yes the printers all work with other programs, Yes I have uninstalled and re installed PSE 13 seems Adobe gets your money and then any sense of support disappears. ie no support of a common problem and their only answer is get the latest drivers but even that does not help May be the last PSE I ever buy. Would never recommend it to anyone after this lack of any effort to fix a bug in the program
Photo of Richard Debertin

Richard Debertin

  • 9 Posts
  • 0 Reply Likes
And Adobe is silent
Photo of Anwesha

Anwesha, Employee

  • 72 Posts
  • 8 Reply Likes
Official Response
Hi All,

Please update your PSE13 to PSE13.1 and see if it resolves your problem.
Refer to article:
https://helpx.adobe.com/photoshop-ele...
for the same.
Photo of Rod Bird

Rod Bird

  • 9 Posts
  • 0 Reply Likes
Unfortunately upgrading to PSE13.1 (and then restarting) has not solved this problem Anwesha.

During our conference call on 22 January your colleague (Harpreet?) was able to solve the problem by remotely reconfiguring ports on my PC. For a few days it worked properly.

But having upgraded to PSE13.1 it is back to where we started. In Editor I select printer A but the print arrives on printer B.

I repeat that the problem does NOT occur in PSE 11 Editor or PSE12 Editor, nor in the Organiser modules of PSE 11, 12, or 13. With this information surely it must be easy to identify where the problem is. Find out what has been changed and go back to the earlier version.
Photo of Rod Bird

Rod Bird

  • 9 Posts
  • 0 Reply Likes
I've just reset my preferences again and restarted, and it seems to be working OK now. I think that the procedure outlined when upgrading from PSE13 Editor doesn't apply when upgrading from PSE13 Organiser.
Photo of Anwesha

Anwesha, Employee

  • 72 Posts
  • 8 Reply Likes
Rod,

It is mandatory to clean preferences before updating to PSE13.1 to resolve this issue.
Glad you got it working.

Thanks,
Anwesha