Photoshop: UI lag in Photoshop CS6 OS X when using "Right Zoom" OS utility

  • 3
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
When I try to select a tool a tool group, e.g. trying to select the Magic Wand by holding down the mouse button on Quick Selection Tool, the drop-down menu for the tool group shows correctly but then the whole program becomes unresponsive. There is a ca three second delay from the moment the drop-down menu appears before Photoshop responds to any action. During this time it doesn't even show a hover effect on any menu items. Needless to say this disrupts my work process every time I need to switch to using another tool and at least triples the amount of time spent on even simple editing.

I also experience a similar lag when zooming. When I release the mouse button after scrubby zooming Photoshop becomes unresponsive for the same threeish seconds and then resumes the scrubby zooming even though the mouse button is no longer down. The same thing happens if I don't use scrubby zoom: let's say I zoom out using alt+mouse button. When I release the mouse button and alt, the program freezes and cursor remains a minifying glass for ~3sec, then the zoom is applied and the cursor is updated to a magnifying glass.

I don't know if these issues are related, but as the lag seems to be of a similar length I thought they might be caused by the same issue.

I've tried changing the draw mode and disabling the use of the graphics processor, but neither has provided any change to the issue I'm experiencing.

I'm using Photoshop CS6 13.0 x64 on a OS X 10.7.4 (MacBook Pro with 2.4GHz Intel Core i5 with 8gb RAM). My GPU is an Intel HD Graphics 3000.
Photo of Eero Laivonen

Eero Laivonen

  • 7 Posts
  • 2 Reply Likes

Posted 6 years ago

  • 3
Photo of Sean Boone

Sean Boone

  • 9 Posts
  • 1 Reply Like
The issue I am experiencing sounds similar to your first paragraph above.

When I try to click on a tool in the Tools Menu, there is a good 5 second delay before I can click anything else in the software. I remember this issue back in CS5.5 but can't recall what the fix was.

If the tool I'm selecting needs to be switched by Clicking + Holding, the entire experience is interrupted by the 5 second delay from the first click.

This is making switching between tools via mouse extremely annoying and difficult. Insight into this issue would be great.

Mac OSX 10.7.4
3.1 GHz i5 / 8GB DDR3
Photoshop 13.0.1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 814 Reply Likes
First, make sure you have the 13.0.1 update installed.
Then try closing the other apps.
And yes, even third party mouse drivers could cause problems.
Photo of Sean Boone

Sean Boone

  • 9 Posts
  • 1 Reply Like
Yes 13.0.1 is latest.
I restarted my machine.
I closed every application except Photoshop CS6 and Finder.
I removed my custom mouse and replaced it with the default Apple mouse.

Still experiencing the tool switching lag unfortunately.

Please advise.
Photo of Eero Laivonen

Eero Laivonen

  • 7 Posts
  • 2 Reply Likes
The problem shown in Sean's video is exactly what I'm experiencing too. I also had a similar experience when running nothing else than Photoshop CS6 (and Finder, obviously) i.e. the problem persists. I didn't try mine with a default Apple mouse this time, but have tried to solve the problem earlier by trying a standard Magic Mouse, to no avail.
Photo of Sean Boone

Sean Boone

  • 9 Posts
  • 1 Reply Like
Awaiting next steps to perform to resolve this issue...
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 814 Reply Likes
No idea - something on a few systems is interfering with normal event processing. But I don't know what is different about your systems - I've already asked for other apps, utilities, and third party plugins...
Photo of Sean Boone

Sean Boone

  • 9 Posts
  • 1 Reply Like
End result is unresolved, issue persists.
Photo of Victor Cuellar

Victor Cuellar

  • 2 Posts
  • 0 Reply Likes
My problem with PSCS6 is when I leave my desk for a couple of minutes/ or simply stop clicking stuff, I call it 'when photoshop is idle'. When im back on my desk and try to resume what I was doing theres extreme lag everywhere, even outside PSCS6. I gotta give it a good minute to get back on track. Its super frustrating, at first i thought it was my office mac (21.5" 3.06 i5 core duo and 4gb RAM) but nope, it does the same thing on my home mac (27" 2.8 Quadcore i7 8GB RAM) I gave up my hopes on an update that'd fix it so im kinda used to the lag. Which is sad Lol.
Excuse my english.
Photo of Eero Laivonen

Eero Laivonen

  • 7 Posts
  • 2 Reply Likes
Finally resolved this issue. For me the lag was caused by a 3rd party program running in the background called 'Right Zoom'. It changes the default behavior of the green button on the top left to maximize the window for all available screen space. Disabling it for Photoshop got rid of the lag.

Hope this helps someone. The way I arrived at this solution was to open the activity monitor and close programs one by one, all the while checking if Photoshops behavior improved.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14170 Posts
  • 1773 Reply Likes
Can other folks let us know if they too are using "Right Zoom" utility and whether disabling corrects the problem?
Photo of Craig Mcleod

Craig Mcleod

  • 1 Post
  • 0 Reply Likes
Hi Disable Right Zoom!
This effects CS5 Indesign and CS6 Indesign, Photoshop and Illustrator.
Indesign CS6 can not change font colours using swatches. However can change a colour using CMYK mixer etc.
Im on a new 3.4Ghz i7 iMac. with OSX 10.8.2
This is not an issue on older machines i.e: intel core duo
To disable it go into Applications>Right Zoom>Ctrl click>Show package contents>Resources>Configure. When the window opens disable the "Activate Right Zoom" box. Forget putting Adobe software in the applications exclusions list within the second window it still causes the same problem.
Shame about right zoom I hope they fix the issue soon...
Hope this info helps
Photo of Victor Cuellar

Victor Cuellar

  • 2 Posts
  • 0 Reply Likes
Currently, none of my iMacs have that "right zoom" everyone's talking about.
Photoshop still lags a little when left idle for at least a minute. BAD LAG im talking about, bad lag.
Photo of imjake9

imjake9

  • 4 Posts
  • 0 Reply Likes
I finally found this topic after nearly an hour of digging, and I can confirm that disabling RightZoom fixes the problem I was having on OS 10.8.2. Furthermore, I was able to add Photoshop to the exclusions list, and it works great, so no harm done. Still this took an annoying long time to find, so it would be helpful if there was some easier method of finding it.
Photo of Craig Mcleod

Craig Mcleod

  • 1 Post
  • 0 Reply Likes
Glad you found the solution to.
My first project prior to finding Rightzoom culprit and solving the lag was a complete nightmare... just about unworkable and up against a deadline.
Photo of Ron Franks

Ron Franks

  • 1 Post
  • 0 Reply Likes
Go into the RightZoom preferences and add exclusions for Photoshop and any other programs (Illustrator?) than might be affected. You will need to have Photoshop running when you add the exclusion so it will see it and give you the option to add the exclusion.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
This is an old topic, have you checked for updates to RightZoom?
I would hope that they've fixed the bugs in RightZoom by now...
Photo of rondfranks

rondfranks

  • 1 Post
  • 0 Reply Likes
It's more of a conflict than a bug. By adding Photoshop to the exclusions list it keeps RightZoom from trying to resize the application's window (Photoshop), and stops the quirkiness of the PS zoom tool. RightZoom really doesn't need to resize PS's windows. It's designed to make the windows maximize (red dot) and remember the last window size (yellow dot).

Since it's a freebie, I'm skeptical that they will update it any time soon, but for many programs it works very well.
Photo of Cam

Cam

  • 7 Posts
  • 0 Reply Likes
For me, this issue was fixed by disabling a setting in BetterSnapTool.

In the Extras tab, make sure none of the boxes are ticked that say "Block the click from passing through tho the window button".

If either of those were on, my zoom was rooted.