Photoshop: Type tool - When I hit space bar cursor go to beginning of line

  • 6
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)
When I'm on line end and hit space bar cursor go to beginning of line but hen if I start type some letters it goes back to end. This is in paragraph text.

In point text when text is align to left (screen)
1. Point text with two lines of text
2. With text tool I clicked between "m" and "n" and wrote "##"
3. This happened after I hit enter

Photo of kubapiechowicz

kubapiechowicz

  • 15 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 6
Photo of kubapiechowicz

kubapiechowicz

  • 15 Posts
  • 0 Reply Likes
BTW: It depends on file. When its once broke it stay broken in that file. If U want I can send that broken file.
I have this kind of bug since CS6 (now CC)
Photo of David

David, Official Rep

  • 3334 Posts
  • 539 Reply Likes
Official Response
Good morning,

Have you played with Arabic or Hebrew text at all? It sounds like you've set your composer to right-to-left and are stuck in that state. You can find full details at https://www.youtube.com/watch?v=gfuw7m... .

If you are using legacy type which must look a certain way or Japanese or Chinese text, then I would suggest using the East Asian engine for all your needs. If you are not, then I would recommend always using the Middle Eastern engine, but make sure you've set your flow of text and justification correctly.

If you still have questions, please let me know.

Thanks,
David
Photo of Gemma Suen

Gemma Suen

  • 1 Post
  • 0 Reply Likes
I tried following this, but like others even when it is set to left-to-right, with multiple restarts (and deleting settings file) the cursor goes to the front and any punctuation will be placed there. Really strange... It must be a broken file :(. The only thing that works for me now is to start again choosing the 'East Asian' text engine which was set by default.
I use Windows 8.1, not sure if that effects anything.
Photo of David

David, Official Rep

  • 3334 Posts
  • 539 Reply Likes
Hi Gemma,

The association between type engine and a type layer is permanent. That means if you are using a file that you already created with the other engine, it will continue to use that engine in the future.

Go ahead, change type engines, and start a new document and you will be fine.

Thanks,
David
Photo of rich alan

rich alan

  • 1 Post
  • 0 Reply Likes
Open the paragraph panel, and down in the lower left corner you''ll see the paragraph directional buttons just above the "Hyphenate" check box... mouse over the buttons, and the tool tip will tell you which is which - or just notice the arrow beside each icon.



Mine was somehow set at "Right to Left". I switched it back and that was that :)
Photo of David

David, Official Rep

  • 3334 Posts
  • 539 Reply Likes
Howdy Rich,

Changing the flow of text can only be done when in the Middle Eastern and Southasian text engine, as that is the only time this UI is displayed. If you're seeing this control, then you are using that text engine.

Thanks,
David
Photo of Ankit Lakhera

Ankit Lakhera

  • 1 Post
  • 1 Reply Like
U r a life saver thanks david
(Edited)
Photo of kubapiechowicz

kubapiechowicz

  • 15 Posts
  • 0 Reply Likes
Hi,
I've already check those settings - it is not a case. I event switch between right-to-left and left-to-right to see how that change type behaving and it does not make "##" to go to the left. (point no 3 on screen)
Photo of David

David, Official Rep

  • 3334 Posts
  • 539 Reply Likes
Good Morning,

In a right-to-left context, numbers are still always written left-to-right...well, at least in Arabic and Hebrew, which is what we support. It REALLY sounds like you have the text flow set R2L; not the alignment. Those are two separate things. If you want I can set up a web-mediated connect session and walk through this issue with you. Just let me know.

Thanks,
David
Photo of kubapiechowicz

kubapiechowicz

  • 15 Posts
  • 0 Reply Likes
Ok. But really I've this option set to "East Asian"
And as I see this setting work for all documents in PS - not for one.

EDIT:
You were right :)
But I turn on "Middle Estern and South Asian" for the first time ever. Then I switch "language option" so the features on paragraph panel shows up.
And indeed flow was set to "right to left".
BUT - how this happened? Is there some keyboard shortcut for this feature? I never turn this option on.
Photo of David

David, Official Rep

  • 3334 Posts
  • 539 Reply Likes
There are controls for text directionality in the paragraph panel. You're absolutely NOT the first person to do it; that's why I recognized the problem so quickly. It's easy to do.
Photo of baby sharma

baby sharma

  • 1 Post
  • 1 Reply Like
Thankyou so much its so helpfull ................................. :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :) :)
Photo of Lai Almario

Lai Almario

  • 1 Post
  • 0 Reply Likes
on Character tab....try to reset your Character settings....that should do the trick! I only use point text, never used a textbox ever! I always have this trouble in Photoshop, at first I just create another text layer as I'm always in a rush...but with the recent issue, I had more time to find a way to fix it....and resetting the Characters helped!!!!
Photo of David

David, Official Rep

  • 3334 Posts
  • 539 Reply Likes
Hi Lai,

Have you checked your language/composer settings?  This is NOT something that we hear about almost ever and is directly tied to which composer you're using.  If you want to get rid of the issue entirely, all you probably need to do is follow the steps outlined...

Thanks,
David
Photo of M-Patry

M-Patry

  • 2 Posts
  • 0 Reply Likes
Character settings reset works, thnx