Photoshop: Type Preferences & Language Options don't coincide

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
My Type preferences are set to "Middle East/South Asia" and Type > Language Options show only "Default" or "East Asia". I need Middle East options so I can "fix" the right-to-left paragraph style that randomly gets applied to new text. I've tried every combination of Type preference setting and Language options, resetting characters, paragraphs, etc. Nothing works.

I've been battling this bug for months and still no fix. There isn't even a workaround so my workflow comes to a complete halt. Would love a useful response from Adobe.

I'm using the latest PS CC version, but it's been happening since CS6.

EDIT** Just noticed in the Type preferences window when switching the setting between Middle East/South Asia & East Asia that "Changes will take effect next time you create a new document". Is there really no option to change the language settings of an existing document?? It's almost 2016. Come on Adobe.
Photo of Dave Mozdzanowski

Dave Mozdzanowski

  • 24 Posts
  • 1 Reply Like

Posted 3 years ago

  • 1
Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Hi Dave,

The text engine settings are on a per document basis for a number of reasons.  Now, you can still switch into them to make certain changes.  It sounds like you're stuck in R2L and need to shift back.

So, switch over to the MENA composer.  Reset your paragraph settings back as you would like.  Then switch back to the East Asian composer and you'll be good.

Not ideal but we do have fixes in the works.

Thanks,
David