Lightroom: Trouble updating LR 1.4 catalogs for use in LR 4.3

  • 1
  • Problem
  • Updated 5 years ago
  • (Edited)
I am having difficulty opening my old Lightroom 1.4 catalogs in Lightroom 4.3. When I try to open an old catalog, it gives me the option to update it, but the process fails, bringing up a dialog box that reads: "Lightroom encountered problems when trying to update the format of the catalog file and cannot use this catalog in this version of Lightroom." What should I do?
Photo of Andy

Andy

  • 2 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Klaus Weber

Klaus Weber

  • 71 Posts
  • 3 Reply Likes
I always upgraded my catalogs after using the latest version after a period of time.

As far as I can remember you can install different versions of LR on the same computer.
After a backup I would go and Install LR2 and do a catalog upgrade using LR2.
I am almost sure I upgraded some of my very old catalogs created with LR2 to LR4.

Certainly not a prooved solution but maybe it helps.
Hopefully someone at Adobe will provide an official answer.
Photo of Andy

Andy

  • 2 Posts
  • 0 Reply Likes
Thank you very much for the suggestion, Klaus.

Unfortunately, I jumped all the way from LR 1.4 to LR 4, so I don't have any old versions of LR 2 or LR 3 lying around. If I did -- or if a utility existed -- I would happily upgrade my LR 1 catalogs in multiple stages.

Thanks again,
Andy
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 104 Reply Likes
Andy, I'd need a copy of your catalog to look into this more. I'll contact you privately for that.

Becky