Lightroom: Trouble upgrading catalog: "Lightroom encountered a problem when trying to update the format of the catalog file and cannot use this caralog in this version of Lightroom"

  • 2
  • Problem
  • Updated 6 years ago
  • (Edited)
I just purchased Lightroom 3 and have install it. When first opening I received the following error message: "Lightroom encountered a problem when trying to update the format of the catalog file and cannot use this caralog in this version of Lightroom". Ideas?
Photo of Richard Abbondanza

Richard Abbondanza

  • 1 Post
  • 0 Reply Likes

Posted 6 years ago

  • 2
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 104 Reply Likes
Try starting Lightroom with a new catalog (hold down the ctrl key when starting Lightroom and choose "Create a new catalog" from the dialog that appears. Then, go to File > Open catalog and select the catalog from your previous version of Lightroom. If that doesn't work, you can try File > Import from Catalog.