Elements 12: Not working after moving to Windows 10

  • 2
  • Problem
  • Updated 3 years ago
  • (Edited)
after the up garde to Win 10 the organiser part of PSE 12 does not work - Lightroom is OK and the Editor part of PSE - now having uninstalled as part of the reinstall process I have no access to PSE12
Photo of Nicholas Hetherington

Nicholas Hetherington

  • 5 Posts
  • 1 Reply Like
  • pissed

Posted 3 years ago

  • 2
Photo of Nicholas Hetherington

Nicholas Hetherington

  • 5 Posts
  • 1 Reply Like
I have had an on-line chat with Adobe tech - he say PSE 12 will not work with Windows 10 - categorically!

he is suggesting using a trial version of PSE 13 which it appears does work with Windows 10

Adobe are researching Win10 & PSE 13 at the momwnt
Photo of Michel BRETECHER

Michel BRETECHER, Champion

  • 971 Posts
  • 189 Reply Likes
PSE12 works fine on Windows 10 for me and other users. Categorically.
For your information, I have upgraded my Windows 8.1 to Windows 10 with PSE13 already installed. No problem. No problem with Lightroom 5.7 nor with Photoshop CC. I have since reinstalled PSE12, PSE10 and even PSE6 with success.
Photo of Nicholas Hetherington

Nicholas Hetherington

  • 5 Posts
  • 1 Reply Like
Thanks for the encouragement - I think i will go ahead and upgrade to PSE13 since i know that my !2 version will not install after several attempts - Win 10 is trying to download a DirectPlay for this and Microsoft state it is now obsolete !!

Thanks for the message