Trash program thinks smart objects are missing when they are not

  • 1
  • Question
  • Updated 3 months ago
Trash program thinks that smart objects are missing when they are not. Went into every smart object, everything opens yet when I try to package it doesn't work.

Restarting and renaming the file does nothing
Photo of Noah Kelber

Noah Kelber

  • 1 Post
  • 0 Reply Likes
  • like I need to find a new program to use for work

Posted 3 months ago

  • 1
Photo of Cristen Gillespie

Cristen Gillespie

  • 1268 Posts
  • 325 Reply Likes
Let me try to understand exactly what is happening. You have brought in Linked Smart Objects. You save and close the file. The next time you open it, it says links are missing, and you have a question mark over your link badge on the thumbnail. Is that correct?
You say you can open the file and see the elements are all present, but you can't package it because PS insists the links are missing. Is that correct?
Because I canĀ  link a Smart Object, save it with or without maximize compatibility enabled, move the linked Smart Object, reopen the file, and still see what I'm missing. This is a good feature, because it can be difficult to find what we can't see. But the file itself is still missing, in actuality. I have to track down the missing file and relink it if I'm going to package it.

Is that NOT what's happening here? When you open your file, do you get a path to the missing link? Are these links to Library assets instead of your hard drive? Have you tried to relink to either source and it fails?
Photo of eartho

eartho

  • 814 Posts
  • 198 Reply Likes
quality post, bro.

makes it real easy to help troubleshoot the issue.

btw, if your SOs are embedded, they don't need to be packaged.