Photoshop: Transparency grid scales with image pixels

  • 1
  • Problem
  • Updated 5 years ago
  • (Edited)
When I zoom in (particularly to a very small image), the transparency checker-board scales with the image pixels, making it difficult to tell what's grey/white and what's just transparent.
Photo of Anthony Carrick

Anthony Carrick

  • 3 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Chris Cox

Chris Cox, Sr. Computer Scientist

  • 20213 Posts
  • 661 Reply Likes
That seems to happen when OpenGL drawing is enabled. Yeah, I find that annoying, but it'll probably take a while to fix.
Photo of Anthony Carrick

Anthony Carrick

  • 3 Posts
  • 0 Reply Likes
Ahh right, I turned off OpenGL in Interface or whichever tab it is, that works.

OK, so you know about it in OpenGL mode then.

Thanks for your help.
Photo of David B

David B, Official Rep

  • 211 Posts
  • 28 Reply Likes
You probably already knew these but I'll pass them along all the same,

I see from your screen shot that the transparency grid size is already set to small, so long as your semi-transparent pixels in your image weren't white, you could also set the grid size to None. Also with the grid option on, playing with the grid colors sometimes helps.
Photo of Anthony Carrick

Anthony Carrick

  • 3 Posts
  • 0 Reply Likes
I hadn't realized you could change the transparency grid actually! I'll keep that in mind too.
Photo of Danny Halarewich

Danny Halarewich

  • 2 Posts
  • 0 Reply Likes
I'm having the same problem, on my new Macbook Pro, running Lion 10.7.1

Except, when I disable OpenGL or change it to "Basic" it does not fix the issue. It changes the scaling, but it does not make the grid fixed pixel size. This behaviour is very annoying.

Each square in my grid should be exactly 1 pixel. I tried changing the size from small, medium to large, and it never matches up to 1 pixel.

Here are some screenshots showing some 1 pixel squares I drew, with the underlying grid not matching up as its way bigger.
Photo of Danny Halarewich

Danny Halarewich

  • 2 Posts
  • 0 Reply Likes
OK, I realized that the usual behaviour is for the grid to be much smaller than 1 pixel at 3200% zoom. On default settings, 4 squares of the grid should fit inside 1 pixel.

On my brand new macbook Pro (AMD Radeon HD 6750M ), and iMac (AMD Radeon HD 6970M w/ 2GB) the transparency grid is way bigger than a pixel, as shown in the screenshots.

After several restarts of the application, and opening new documents, disabling OpenGL completely has solved the problem it seems.

Please try and fix this issue on the newer hardware. I have some slightly older Macs and they do not have this problem with OpenGL - basic or normal enabled. It would be nice to experience the performance enhancements like others.
Photo of David Dobish

David Dobish, Senior QE Photoshop

  • 174 Posts
  • 30 Reply Likes
Hello I worked on the OGL canvas feature for Photoshop.

The reason it is scaling different is because you have OGL mode set to Basic.

If you set it to Normal or Advanced the transparency grid will not increase in size as you zoom in. In other words it should match what it looks like when OGL is OFF.