Photoshop CS6: Free Transform is unavailable when a vector layer is selected

  • 1
  • Problem
  • Updated 1 year ago
  • (Edited)
While it's possible to add a regular layer mask (in addition to a vector mask) to a vector-based layer, it's rather difficult to do much editing with the mask.

I usually rotate and scale masks using Free Transform, but with vector layers, the edit menu only offers "Free Transform path," even when I have un-linked the layer mask and selected it alone. In fact, even when I alt-click into the layer mask itself, I can't Free Transform.

I'm pretty sure that this is a new behaviour.
Photo of James Monaco

James Monaco

  • 31 Posts
  • 10 Reply Likes
  • frustrated

Posted 6 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
IT sounds like you're using Photoshop, but you didn't say..

And which version are you using?

I've never seen Free Transform disabled with targeting a vector shape or vector mask.
Photo of James Monaco

James Monaco

  • 31 Posts
  • 10 Reply Likes
Yup, Photoshop! I checked it in the little Products box, but it doesn't seem to show on here...

It's CS6, version 13.0 x64
Photo of James Monaco

James Monaco

  • 31 Posts
  • 10 Reply Likes
Hm--my Updates is greyed out at the moment, but I'll try to get that sorted and report back.

(Ahh, I think that's it)
Photo of James Monaco

James Monaco

  • 31 Posts
  • 10 Reply Likes
Ok, got the update, still doing it. Just to clarify, it's not that it is disabled, it's that it is not there. Typically, when you (or I) select a vector shape layer or a path, the Edit menu shows "Free Transform Path" instead of "Free Transform." This swap is normal and expected, because Free Transform is for bitmap graphics and vector paths are paths.

The problem that I'm running into is that the act of selecting the layer mask (a bitmap graphic) on any layer containing a vector shape fails to swap back to Free Transform, and stays at "Free Transform Path." This has the unpleasant effect of modifying the shape of an object on a layer, instead of modifying the shape of the mask.

I'm attaching a short screen cap clip with an example. First, I place a mask on a vector layer and attempt to Transform the Mask, not the layer. This does not work as you will be able to see. Then, I place a mask on a regular layer and easily Transform the Mask, separately from the layer, as desired.

http://www.screencast.com/t/bZV9y6dj4Ea
Photo of Felix Tsetlin

Felix Tsetlin

  • 1 Post
  • 0 Reply Likes
Same problem here. Very annoying.
Photo of Bolinho De Arroz

Bolinho De Arroz

  • 1 Post
  • 0 Reply Likes
Solution: right click on the vector layer and press "rasterize layer", do it on every layer and your done.
Photo of James Monaco

James Monaco

  • 31 Posts
  • 10 Reply Likes
Getting rid of vectors isn't a solution for something not working with vectors. Happily, however, this isn't an issue anymore; Adobe has fixed the issue, and it is now possible to scale bitmapped layer masks on vector shape layers by unlinking the mask.
Photo of Thomas Fournier

Thomas Fournier

  • 1 Post
  • 0 Reply Likes
You need to have no path selected on  your Path window. It will unlock the Free Transform option.
Photo of Cristen Gillespie

Cristen Gillespie

  • 1231 Posts
  • 320 Reply Likes
Actually no, at least not in CC 2017. I believe the OP was on CS6, and I frankly don't remember how it might be different there. In CC, unlink the mask and with or without the path targeted in the Paths panel, FT is available.