Photoshop CS6: tools quit working, history shows action but tool doesn't actually work.

  • 2
  • Problem
  • Updated 3 years ago
  • (Edited)
PS6 still looses tool functions. Also lost the batch functions through the bridge. CS5 was not as bad as previous versions but it's back in 6. Seems PS should have fixed this problem..... I should have to reset things to make it work properly. Plus I have to stop working and clear the file.
Photo of Cindy Rodney

Cindy Rodney

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 5 years ago

  • 2
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 767 Reply Likes
What OS version?
Have you installed all the updates for Photoshop CS6?

If history shows the tool action, then some work was done.
So it could be that your video driver is failing to display the change, or that the tool settings make a change that isn't visible (like multiplying with white).
Photo of Cindy Rodney

Cindy Rodney

  • 3 Posts
  • 0 Reply Likes
Windows 8
My software is from the cloud, check all and all up to date!
I had the clone tool at 100%, it just stopped working. but it is registering in the history. I've used PS for 15 years it use to happen a lot in earlier versions. I reset the preference file. The tools are working again, but the batch processing won't work. I talked with Adobe and they need to sign onto my machine to see what's causing the hang ups. Any ideas on your end!
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 746 Reply Likes
So you have version 13.1.2? (AAM sometimes fails to see updates)

Resetting the preferences fixing it means that most likely you just had a tool setting that made the effect not visible, or that your video card just wasn't drawing the result and you reset the GPU preferences.
And I don't know what you mean about batch processing -- you're still leaving out a lot of important details.
Photo of Cindy Rodney

Cindy Rodney

  • 3 Posts
  • 0 Reply Likes
Version 13.1.2 x64!
OK! So several tools didn't work, the clone tool, burn tool, dodge tool.... My machine is just a couple of months old. I had it built for what I do, I'm a photographer 22 years now, 18 full time. I have two computers, one in each studio, that are built to handle the amount of graphics I do, both have top of the line graphics cards . I just photographed 65 competitive cheerleaders. I batch process these large jobs, writing an action, that does several things to the portraits. This machine has windows 8, the machine in my other studio has window 7. I haven't had this problem as much with windows 7. According to Adobe, re-setting the preference file is the way to correct the problem. After I reset that file, the batch processor still doesn't work. (In bridge you can grab a group of pictures and batch process them. The step are Tools, Photoshop, batch, then it goes to PS and a menu come us that ask what set and action to run.) the batch will go from the bridge to PS, but when the PS screen comes up, the menu that ask what you want to do does not. So it won't batch process an action! And yes the actions do work, they worked for about 15 of the girls, then just stopped working. I've re-booted several times, the batch process is now working.... can't tell you what I did... nothing - but it is working. Batching is a very important part of my work flow.
I even right in the action other PS plug in like On One Software, Nik, Topaz. Without the batch it would take days to get the final look that my clients except. PS users have had to reset the preference file for years because the tools stop working properly! This is nothing new, just thought that Adobe would have figured it out by now.
Photo of patrick shannon

patrick shannon

  • 4 Posts
  • 0 Reply Likes
Just going through the same myself, rotate works then stops, everything up to date. IF YOU SAVE YOUR WORK AND RESTART THE PROGRAM, IT WILL START WORKING AGAIN.

I hope this helps.
Photo of Maethius

Maethius

  • 2 Posts
  • 0 Reply Likes
Same issues: Windows 7 (company computer, maybe they'll upgrade, but not an option for me), CS6 (not cloud). Tools suddenly stop responding; marquis, all forms of painting tools, type tools, etc. Space bar no longer "hand drags." I CAN select layers, and choosing new tools does update the cursor properly; I can even select and replace text (if my aim and memory is sharp!) Zoom affects the RULERS, but not the image. History updates as normal, but no visual changes in the document.

Saved my work and immediately reloaded the FILE, and that also worked. Incidentally, this project has required my using Photoshop alongside my browser, which is Chrome... I'll see what happens if I use different browsers.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 764 Reply Likes
You may need to disable GPU drawing in Photoshop to avoid this.
But you should also try updating your video card driver from the GPU maker's website.
Photo of Maethius

Maethius

  • 2 Posts
  • 0 Reply Likes
I'll give it a go, thanks!