Tools Pop Out Submenu Constantly

  • 1
  • Problem
  • Updated 9 months ago
Every time I click on a tool on the toolbar, the sub-menu pops out and I then have to click on the tool again within the sub menu, or click off of the toolbar to close the menu. It's rather annoying, and only happens on my Mac Pro (trashcan). I've tried resetting all settings in preferences, but it only worked temporarily. Now it's back and here to stay, it seems. (2017.1.2 release)
Photo of Ben

Ben

  • 7 Posts
  • 0 Reply Likes
  • Annoyed

Posted 9 months ago

  • 1
Photo of David

David, Official Rep

  • 2800 Posts
  • 390 Reply Likes
Howdy Ben,

Are you using a tablet or stylus with this machine?  Any unusual pointing device?  How about keyboards?  Language setup?  It sort of sounds like you might have some sort of input conflict or overload.

Also, any reason you haven't updated (just so that I know you have the latest-greatest)?

Thanks,
David
Photo of Ben

Ben

  • 7 Posts
  • 0 Reply Likes
Appreciate the suggestions, but nothing seems to be working. I don't believe I have any unusual shortcuts or anything enabled or set. I'll try swapping the mouse out next.
Photo of Ben

Ben

  • 7 Posts
  • 0 Reply Likes
It ONLY does this in Photoshop. Illustrator and AE all seem to be working normally, which leads me to believe it's an issue with PS only, and not something outside the program.
Photo of David

David, Official Rep

  • 2800 Posts
  • 390 Reply Likes
Howdy Ben,

It could be that Photoshop is also running afoul of something the other apps don't use.  It sure wouldn't be the first time.

Did you try Jeff's suggestions?  Are you open to do a web-hosted screenshare so I can see the issues you're having in real-time and try to troubleshoot them with you?  All you need is a 'net connection, browser window (Chrome is better), and phone.  The call is toll-free.  I'm on Pacific time.

Let me know...

Thanks,
David
Photo of Ben

Ben

  • 7 Posts
  • 0 Reply Likes
It's crazy that it's working normally now. It's been doing this for over a year, and as soon as I start whining about it, it stops doing it. I'll let you know if it starts doing it again, but for now it seems to be ok.
Photo of grauenwölfe

grauenwölfe

  • 216 Posts
  • 81 Reply Likes
If it starts acting up again try setting your ‘Double-Click speed’ down one tick in System Preferences.