Photoshop CC 2019: Tool display bugs

  • 5
  • Problem
  • Updated 4 weeks ago
  • (Edited)
Just upgraded to Photoshop CC 2019 and i'm noticing some display bugs with a range of tools.


  • The lasso tool doesn't display your selection while drawing. When adding to the selection, you can see the selection you're drawing. The quick work around is draw a small selection and then draw your real selection by shift-dragging. But it's just annoying.
  • When using the brush tool you very quickly get a 'spinning balls' cursor, instead of your brush size. This makes precision painting a real pain, as you can no longer see the edge of your brush.
  • Then there is the free transform tool. You used to get a bounding box with points around it from where you can drag the different transforms. Now you have to go and guess where to place your cursor to do anything. It makes the transform tool quite unusable. The 'fix' is to turn off graphics acceleration in your preferences, but this used to work just fine in previous versions with GPU acceleration.

My guess is that Adobe has changed the way tools are rendered on-screen (The rectangular marquee selector is now coloured, for instance), but clearly more work needs to be done.  These problems persist along a range of iMacs and MacPro's at my office, all are running macOS Mojave and are no older than 5 years.


Below is the system info for my particular iMac

Thank you,

Photo of Evert Krooswijk

Evert Krooswijk

  • 2 Posts
  • 1 Reply Like

Posted 4 months ago

  • 5
Photo of Adam Jerugim

Adam Jerugim, Employee

  • 214 Posts
  • 102 Reply Likes
Hi Evert,

I have the exact same iMac (same specs for CPU, GPU, and RAM) running 10.14 and I'm not seeing any of these issues.

A couple of questions:

Are you driving the app with a mouse or tablet?

What type of document are you working with (layers, bit depth, color space, etc)?

I assume you've tried resetting your PS preferences, but if you haven't you might want to try that.

Can you also confirm you're on the final release of 10.14?

Photo of Evert Krooswijk

Evert Krooswijk

  • 2 Posts
  • 1 Reply Like
Hi Adam,

Thanks for the reply. I usually work with a mouse (Logitech MX Master), but I do have a Wacom tablet attached.

I'm working with layered CMYK document (so 8 bit). I hadn't reset the prefs as it was a brand new install (but now that I think of it, it copied over the prefs of the previous install)

I Checked and i'm on the latest version of Mojave.

HOWEVER: I did manage to get things back to normal by setting the drawing mode to 'Basic' in the Advanced settings.

I will try out what happens without a Wacom attached and/or a fresh prefs file and get back on that, though.

Photo of Margrit Fritsch

Margrit Fritsch

  • 1 Post
  • 0 Reply Likes
Thanks for your tip! I had the same display bugs. Margrit
Photo of Glenn Davy

Glenn Davy

  • 38 Posts
  • 13 Reply Likes
I'm seeing the same issue here as I just updated to Mojave a few days ago. I'm working on both JPEG's and PSD files and on neither do I get the tool outline as well (I have the same issue as reported above, in other words). I am using a Wacom Intuos Pro but I tried it using just the trackpad and I got no outline there either. I have reset my preferences but that didn't help. As well, I get the spinning wheel when working with brushes. What I think has happened here is that Apple has switched to Metal instead of OpenGL for their video. This was announced last year and has had game designers scrambling, but until now I don't think it's been in place. With Mojave it is, as far as I can tell, and I am guessing that's where the issue lies. I just wonder why Adobe hasn't picked up on this, IF this is what the root cause is. Anyway, I too have switched to the Basic Mode as reported above and that has worked, but there seems to be quite a number of visual bugs in this release that I hope get corrected ASAP.

Photo of brian


  • 6 Posts
  • 1 Reply Like
Same here. That lasso path not showing up as you're drawing makes it quite tricky to use. (Late-2011 MacBook Pro 15", using the built-in trackpad. Mac OS X 10.13.6 High Sierra. 8 GB RAM. [Yes, I will need to upgrade my laptop before long, as Mojave marks the first version of OS X that no longer supports my hardware.])
Photo of robotriot


  • 5 Posts
  • 0 Reply Likes
I have a similar problem with CC 2019 on Windows 10. Rectangular marquee selections keep disappearing when moving them around within one document. Sometimes the entire selection disappears, sometimes only the vertical lines.

I've had an even stranger problem with a file that contains several identical labels for printing, each surrounded by a 1 pixel wide border. I noticed that sometimes, parts of the lines would disappear (depending on how you move the document around with the hand tool), and my printer would print exactly what was visible in Photoshop, including partially missing lines. I've printed the exact same files for several years now withough any problems on older Photoshop versions.
Photo of Erik Jakobsson

Erik Jakobsson

  • 25 Posts
  • 1 Reply Like
Got at least one of these issues.

Cursor rendering is buggy overall, this includes the pink brush smooth line.

Lasso tool is very dodgy... will disappear in the start or middle of a stroke so as often as not you don't see what you're doing.

Sometimes layers get rendered quite mistakenly.
(Fill value wrong, z-order mistakes in rectangular areas)
I have to go in and nudge these parameters a bit and then back to tell PS to notice they were off and re-render these layers and refresh the "mixdown".

Loving opengl flip so happy enough! :-)

PS 20.0.1 (Basic, Legacy compositing) on an Asus F555L - Win 10 64-bit
Photo of Jerry Scullion

Jerry Scullion

  • 1 Post
  • 1 Reply Like
Open a RGB file, and draw a selection. BAM you have the selection outline. Then go back to your CMYK file and it works. Why? I don't know. But it does.
Photo of Xiao-dong Xu

Xiao-dong Xu

  • 1 Post
  • 0 Reply Likes
It's so weird. I have this issue on Mac Pro (High Sierra), and have no issue on Macbook Pro (Mojave). ADOBE! Have you given the software enough test before delivery? Cause the problem is so obvious and what I can do is to go back to PS 2018.