Lightroom Mobile: Tif smartpreviews not updated in develop mode in mobile

  • 2
  • Problem
  • Updated 2 weeks ago
  • Acknowledged
  • (Edited)
Ok first the setup:
I start with LR Classic (in a shared album, smart-previews in the cloud) and send a RAW to Photoshop, after I'm done with my edit the saved tiff gets added my LR classic and automatically added to the shared album as a smart-preview too (thats nice).

In LR Mobile I can see my edit in develop mode and in the preview, so far so good.

Then later I continue working on that tiff (sending it to Photoshop via LR Classic again, so LR gets the update). And it does get the update, LR classic shows the changes I have done.

Back to mobile, here I get the old version in develop mode, the preview thumbnail gets updated to the new version, if I open the tiff smart-preview into activity, rating, or info view, I see the updated version as it should be.

But if I get into develop mode in LR mobile, it shows the current version (as it should be), but only for a second and then switches to the version that was first shared when I saved the first edit (that is now outdated and not what LR classic shows or whats actually in that file).

If I switch from develop to the activity, rating, or info views it remains the incorrect older version, If I get back and go into activity, rating, or info view directly without going through develop, its the current version as it should be again.

Biggest problem, on export I always get the old outdated version of this photo, even if I don't export out of the develop mode view.
Photo of Donna Wetter

Donna Wetter

  • 110 Posts
  • 10 Reply Likes

Posted 5 months ago

  • 2
Photo of Yves Crausaz

Yves Crausaz

  • 786 Posts
  • 113 Reply Likes
It is normal, it is badly messed up .... LR mobile is that for the development made in LR Classic or Mobile, it does not 'yet' know how to process files edited in editors external to LR. And probably it never will be.
Look at how is integrating PS and PS mobile and you will understand!
(Edited)
Photo of Donna Wetter

Donna Wetter

  • 110 Posts
  • 10 Reply Likes
No its not normal, if the thumbnail updates correctly so should the whole smartpreview.
(Edited)
Photo of Donna Wetter

Donna Wetter

  • 110 Posts
  • 10 Reply Likes
The Lightroom Web interface also shows the correct photo in develop mode.

So its definitely a bug in LR mobile Android not getting the info that the file was updated.
(Edited)
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7714 Posts
  • 1778 Reply Likes
Not necessarily. If you go to https://lightroom.adobe.com and look at the TIF after the second edit, has the second edit made it to the cloud?  This may be Lightroom Classic failing to send the re-edited version to the cloud rather than Android failing to pull it back down.
Photo of Donna Wetter

Donna Wetter

  • 110 Posts
  • 10 Reply Likes
One detail, the albums are set to "store locally" on the mobile devices, maybe it has something to do with it.
(Edited)
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7714 Posts
  • 1778 Reply Likes
With Store Album Locally enabled, I can duplicate this. I will log a bug with the Android team. Thanks for the report. 
Photo of Donna Wetter

Donna Wetter

  • 110 Posts
  • 10 Reply Likes
Thank you.
Photo of Donna Wetter

Donna Wetter

  • 110 Posts
  • 10 Reply Likes
This is still not fixed.  :(
Photo of Donna Wetter

Donna Wetter

  • 110 Posts
  • 10 Reply Likes
Hows the fix coming along? Its still annoying having outdated photos in the LR app and accessing them via the web interface to get the correct version.